You've been disconnected message on Android App

Hello everyone,

I was able to succesfully deploy my Jitsi Server on a Ubuntu Machine.
I had this same problem, but solved it by creating a local A DNS record on my DNS server pointing hostname to local IP.

I’ve downloaded the android app and while being connected to Wi-Fi, I tried to access the name of the meeting in questions but now I keep getting the reconnect message, unable to use the app on it entirely.

If this is a certificate problem, I tried using the let’s encrypt scrip on this tutorial, but gave me an error message, so there’s no certificate, not even a self-signed one. However, on the network accessing through browser, it works really well.

This is the guide I followed:

Any help? Any logs you want me to post? Thanks!

Hi and welcome.
The correct guide for installing is https://jitsi.org/qi.
In order let’s encrypt to work you need a valid DNS record to a public address of your server in order the let’s encrypt service to be able to connect to your instance from Internet.
Mobile apps will not work without a valid certificate.

So, even if I had the self signed certificate, the mobile app still would not work if there is no public DNS record? Even if Im inside the internal network through Wifi and an internal DNS record as I currently have?

The mobile app will not work with self signed certificate.