"You have been disconnected" when running behind FRITZ!Box with NAT

HINT: I have replaced the real domain in all logs and configurations posted here with meet-example.com

I have setup a new jitsi-meet server on Ubuntu 18.04 LTS
The server is installed as VM on ESXi 7.0.0
I used the quick install
Let’s encrypt certificates have been successfully created.

The server is behind a Fritz!Box 7390.

I have opened ports 80, 443 and 10000/UDP on the Fritz!Box

Everything works fine with this settings.

I have another server running that listens on port 443 for HTTPS and so I reconfigured the NAT and opened port 444 forwarding to port 443 for the Jitsi server

I con open the welcome page and everything looks good so far.
I can open a new meeting, but the meeting is not working properly.

Some elements are missing, i.e. setting the password for the meeting. I am also not able to close the meeting by clicking the “hang up” button.

After a while, a “You have been disconnected” message appears.

I already followed the instructions in advanced-configuration with no success

org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=meet - example . com

In the console log in Chrome I see a couple of errors, but I have no idea, how to fix them. you can find the log here https://1drv.ms/u/s!ApSDY4LPNG1WlUAh5GHsYz5ktLuu?e=DowEsr

Pls. bare with me. I am new to Jitsi. Any help is appreciated.

Try open TCP port 4443 as well it is used for the link between clients to the jitsi videobridge

Thanks for the quick reply. I have added port 4443 to the list of opened ports pointing to jitsi server. But that did not solve the issue.

I then modified /etc/jitsi/meet/meet-example.com-config.js

and added port 444 to the BOSH configuration

// BOSH URL. FIXME: use XEP-0156 to discover it.
bosh: '//meet-example.com.de:444/http-bind',

I also reset the values in


to its DEFAULT values

After I have restarted the VM, everything works fine now.

1 Like