You have been disconnected message

My Public IP address is pointing to a fully qualified domain name and I am able to host the Jitsi Meet on my own domain name. However, when I am trying to join a meeting, it says you have been disconnected and a rejoin now button gets activated. A lot of people have faced this issue but I am not able to find my source of the issue. I have hosted the server on Ubuntu 18.04.3 LTS.
I would also like to mention that the public IP address is not giving a ping response. It says destination host unavailable.


The error on the Developer’s tools console is the following.
021-11-18T13:25:26.079Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: Strophe: BOSH-Connection failed: improper-addressing Script: null Line: null Column: null StackTrace: Error: Strophe: BOSH-Connection failed: improper-addressing
at Object.r.Strophe.log (dom.name/libs/lib-jitsi-meet.min.js?v=5415:17:16530)
at Object.error (dom.name/libs/lib-jitsi-meet.min.js?v=5415:1:24712)
at O.Bosh._connect_cb (dom.name/libs/lib-jitsi-meet.min.js?v=5415:1:52246)
at w.Connection._connect_cb (dom.name/libs/lib-jitsi-meet.min.js?v=5415:1:36967)
at O.Bosh._onRequestStateChange (dom.name/libs/lib-jitsi-meet.min.js?v=5415:1:56102)
o @ lib-jitsi-meet.min.js?v=5415:sourcemap:10
lib-jitsi-meet.min.js?v=5415:sourcemap:10 2021-11-18T13:25:26.080Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: BOSH-Connection failed: improper-addressing

Is the issue that the Static IP is not pingable? The Static IP address and the domain name both are giving the same response that is Destination Host Unreachable. Is there any way to fix it? Any help would be appreciated.

If the domain is not reachable, that’s definitely a problem. Did you open all required ports? Are they properly forwarded if you’re operating behind a NAT?

Yes, actually I am working on a university project and all the ports are apparently opened from the college’s router side (according to college’s admin; also I can use their server’s virtual machine from my laptop through ssh). I have killed the processes at the relevant ports i.e, 80 and 443, and I restarted the nginx server to ensure that no other process is using those ports. Still the connection issue was prevalent. Also, I have not enabled the firewall, ie firewall ufw is disabled. Is this what you are talking about? Or is there any other way I can ensure port forwarding and opening?

The ports may be open, but not properly forwarded, if behind a router. You need at the very least ports 80/tcp, 443/tcp and 10000/udp. If ufw is completely disabled (not advised), then they should be open on the server (baring the possibility that your hosting company could have some other system-level firewall that you may need to punch through). Now being that your Jitsi server is operating behind a router, you’ll need to forward those 3 ports to the server using the router’s specific forwarding rules/process.

But you have another issue here, which is that you can’t even reach the domain. That’s the first problem to solve. Check with the domain host to figure out what could be the issue.

As an option you may try this installer. It checks many conditions during the installation and gives advices if something goes wrong.

But Ubuntu 18.04 is not supported. Ubuntu 20.04 or Debian 10 Buster or Debian 11 Bullseye is needed.