Xmpp_username_override Does Not Work For IFrame

After reviewing many of the threads, I think its apparent that xmpp_username_override and xmpp_password_override do not work…or I should say you have to manually go into your browser’s cookies and change the subdomain, which isn’t pratical.

And the JWT implementation currently doesn’t work without long workarounds. And its a little hard to get clear answers on the forums here.

A suggestion I would have is make the username and password be password passable via an execution. For example:

let credentials = {'login': 'foo', 'password':'bar'};
const api = new window.JitsiMeetExternalAPI(domain, options);
api.executeCommand('login', credentials);

Any others with thoughts on this?

1 Like

Maybe this will help once it goes in https://github.com/jitsi/jitsi-meet/pull/7788

Hi This looks just like what I’m after.

How do I go about using the appData? Is it like this?

const options = {
roomName: 'ROOMNAME2',
width: 700,
height: 700,
configOverwrite: {
  startWithAudioMuted: true,
}, 
interfaceConfigOverwrite: { 
  TOOLBAR_BUTTONS: [
    'microphone', 'camera', 'hangup', 'profile', 'settings', 'raisehand',
    'videoquality'
  ] 
},
userInfo: {
  email: 'Conference Set Up User',
  displayName: 'Admin User',
},

appData: {
  XMPP_USERNAME_OVERRIDE: 'username',
  XMPP_PASSWORD_OVERRIDE: 'mysupersecretpassword',
},
parentNode: document.querySelector('#meet'),
};
const api = new JitsiMeetExternalAPI(domain, options);