XMPP Server No Components

Hi,

I have installed Jitsi manually(old release) (version jitsi_videobridge1)

after configuration have this error:

JVB 2020-04-08 10:29:37.032 SEVERE: [17] org.jitsi.videobridge.health.Health.log() Health check failed in 0ms:
java.lang.Exception: No XMPP components
at org.jitsi.videobridge.health.Health.checkXmppConnection(Health.java:269)
at org.jitsi.videobridge.health.Health.doCheck(Health.java:225)
at org.jitsi.videobridge.health.Health.doRun(Health.java:495)
at org.jitsi.utils.concurrent.PeriodicRunnableWithObject.run(PeriodicRunnableWithObject.java:87)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.run(RecurringRunnableExecutor.java:216)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.runInThread(RecurringRunnableExecutor.java:292)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.access$000(RecurringRunnableExecutor.java:36)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor$1.run(RecurringRunnableExecutor.java:328)
JVB 2020-04-08 10:29:39.184 SEVERE: [27] org.jitsi.meet.ComponentMain.log() not-authorized, host:127.0.0.1, port:5347

and:
org.jitsi.meet.ComponentMain.log() not-authorized, host:127.0.0.1, port:5347
org.xmpp.component.ComponentException: not-authorized

My: sip communication:

org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.mydomain.com/.*
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=xxx.xxx.xxx.xxx
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=xx.xx.xx.xxx

My prosody:

-- Plugins path gets uncommented during jitsi-meet-tokens package install - that's where token plugin is located
--plugin_paths = { "/usr/share/jitsi-meet/prosody-plugins/" }

VirtualHost "for-meet-8.formretail.it"
        -- enabled = false -- Remove this line to enable this host
        authentication = "internal_plain"
        -- Properties below are modified by jitsi-meet-tokens package config
        -- and authentication above is switched to "token"
        --app_id="example_app_id"
        --app_secret="example_app_secret"
        -- Assign this host a certificate for TLS, otherwise it would use the one
        -- set in the global section (if any).
        -- Note that old-style SSL on port 5223 only supports one certificate, and will always
        -- use the global one.
        ssl = {
                key = "/etc/prosody/certs/xxxxxx";
                certificate = "/etc/prosody/certs/xxxxxx";
        }
        -- we need bosh
        modules_enabled = {
            "bosh";
            "pubsub";
            "ping"; -- Enable mod_ping
        }

        c2s_require_encryption = false

Component "conference.xxxxx" "muc"
    storage = "internal"
    muc_room_default_moderated = true
    muc_room_default_language = it
    --modules_enabled = { "token_verification" }
admins = { "focus@auth.xxxxx" }

Component "jitsi-videobridge.xxxxx"
    component_secret = "ok"


VirtualHost "guest.xxxxx"
        authentication = "anonymous"
        c2s_require_encryption = false


VirtualHost "auth.xxxxxx"
    ssl = {
        key = "/etc/prosody/certs/auth.xxxxxx";
        certificate = "/etc/prosody/certs/auth.xxxxx";
    }
    authentication = "internal_plain"

Component "internal.auth.xxxxxx" "muc"
    modules_enabled = {
      "ping";
    }
    storage = "none"
    muc_room_cache_size = 1000


VirtualHost "recorder.auth.xxxxxx"
   modules_enabled = {
           "ping";
   }
   authentication = "internal_plain"


Component "focus.xxxxx"
    component_secret = "TM3zg@wy"

MY jicofo config sip:

org.jitsi.jicofo.auth.URL=XMPP:auth.mydomain
org.jitsi.impl.reservation.rest.BASE_URL=https://xxxxxxx
org.jitsi.jicofo.auth.DISABLE_AUTOLOGIN=true

my jicofo conf

 Jitsi Conference Focus settings
# sets the host name of the XMPP server
JICOFO_HOST=localhost

# sets the XMPP domain (default: none)
JICOFO_HOSTNAME=mydomainxxxxx

# sets the secret used to authenticate as an XMPP component
JICOFO_SECRET=TM3zg@wy

# sets the port to use for the XMPP component connection
JICOFO_PORT=5347

# sets the XMPP domain name to use for XMPP user logins
JICOFO_AUTH_DOMAIN=auth.for-meet-8.formretail.it

# sets the username to use for XMPP user logins
JICOFO_AUTH_USER=focus

# sets the password to use for XMPP user logins
JICOFO_AUTH_PASSWORD=nRkHB1Hj

# extra options to pass to the jicofo daemon
JICOFO_OPTS=""

the user prosody matching password whits authuser.

prosody listen on 5347.

can you help me?

Thanks

Resolved…
the JVB_SECRET not correctly and not match with prosody.

RESOLVED.

Hello, I have met the same problem as you. How can I solve it?Looking forward to your reply.thank you

1 Like

Hello, I have met the same problem as you. How can I solve it?Looking forward to your reply.thank you

1 Like

Hi thanks, but which parameter in the prosody config needs changing?

1 Like

Just to answer myself, my server is running now and the logs look fairly clean:

Component "jitsi-videobridge.your-virtual-server"
component_secret = "your-jvb-secret"