WSS works on Firefox but not on Chrome

Hi there,

I have setup which works with WSS on Firefox but not on Chrome.

On Chrome I get following error:

WebSocket connection to ‘wss://jitsi.6og.net/xmpp-websocket?room=s4’ failed: Connection closed before receiving a handshake response

Any clues what it might be?

1 Like

Does your setup have turnserver and nginx multiplexing enabled?

It is default install which comes from quick install tutorial.

How should I check that?

Check whether you have /etc/nginx/modules-enabled/60-jitsi-meet.conf
We have seen that mutiplexing does not work with websockets.

Yes I do have that file

So your option is to move it away. Change your virtual host from listening on port 4444 back to 443 and wss will start working.
The wss implementation in Chrome does not set ALPN on the link and that breaks the multiplexing and forwards your stream to the turnserver not to the virtualhost.

Will do it, thanks. What is benefit of having multiplexer?

Running turnserver and serving web both on tcp port 443. We are planning maybe remove that as people are constantly having problems with that.

this is jitsi-meet nginx module configuration

this forward all http traffic to the nginx virtual host port

and the rest to the turn server

stream {
upstream web {
server 127.0.0.1:4444;changes the port to 443 but i am still getting the same error
}
upstream turn {
server 127.0.0.1:5349;
}
# since 1.13.10
map $ssl_preread_alpn_protocols $upstream {
~\bh2\b web;
~\bhttp/1. web;
default turn;
}

server {
    listen 443;
    listen [::]:443;

    # since 1.11.5
    ssl_preread on;
    proxy_pass $upstream;

    # Increase buffer to serve video
    proxy_buffer_size 10m;
}

}
~
7,29 All
ubuntu version = 18.04
code from file =vim /etc/nginx/modules-enabled/60-jitsi-meet.conf