With jitsi update: No SSRC lines found in remote SDP for remote stream

Hi,

When updating to the new jitsi 1.0.5764-1 and JVB 2.1-592 there are some new error messages in the browsers console: “UnhandledError: No SSRC lines found in remote SDP for remote stream” when connecting trough the JVB.

The Stream does establish and it does seem to work. I was just wondering why the error message shows up now and if there is some unstability in some of the connections I could improve.

5 Likes

I’m using jitsi in kubernetes. So using docker tag: stable-6865
doing some tests with various machines
2 mac book pro (fully updated)
1 android (fully updated)
1 windows 10 (not really up to date - using chrome 98.0.4758.82)

As soon as the windows 10 joins a conf I got the same error.

I tried with edge with the same laptop and no issues. Can’t explain why it’s happening though.

2022-02-08T08:12:36.310Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: No SSRC lines found in remote SDP for remote stream[msid=e7d4d2fc-audio-1,type=audio] Script: null Line: null Column: null StackTrace: Error: No SSRC lines found in remote SDP for remote stream[msid=e7d4d2fc-audio-1,type=audio]
at ua._remoteTrackAdded (https :// myjitsibackend /libs/lib-jitsi-meet.min.js?v=139:2:547325)
at _usesUnifiedPlan.onTrack (https :// myjitsibackend /libs/lib-jitsi-meet.min.js?v=139:2:540431)
at RTCPeerConnection.r (https :// myjitsibackend /libs/lib-jitsi-meet.min.js?v=139:2:226237)

2 Likes

I have the same on stable-6865. Have you solved the problem?

Lib jitsi meet has a fix which also fixes a screenshare problem. Build it yourself and overwrite the files in libs

Which version of lib-jitsi-meet has this fix? And does this version compatible with stable-6865 in jitsi-meet?

We’ve build the latest master

Given that the project since at least one year ships regularly a new stable version roughly on a monthly basis, and the latest stable version is now more than a month old, I’m not sure that you should bother with a non fatal problem.

Indeed new stable 7001 is out.

Yes, not getting it with the latest stable anymore