With docker-jitsi-meet, how can i allow anonymous user?

Question: How can i allow anonymous access using docker-jitsi-meet ?

I know setting prosody config like below allows anonymous access.

VirtualHost "example.com"
    authentication = "anonymous"
    c2s_require_encryption = false

But docker-jitsi-meet generates config files based on .env, i can’t set up prosody config manually.

Even if modify ENABLE_GUESTS=1 in .env file, generated prosody config file doesn’t include authentication = "anonymous" settings. (results below)

VirtualHost "guest.meet.sys5.co"
    -- https://github.com/jitsi/docker-jitsi-meet/pull/502#issuecomment-619146339

    authentication = "token"

    app_id = ""
    app_secret = ""
    allow_empty_token = true

    c2s_require_encryption = false

Have you tried setting ENABLE_GUESTS = 1?

Yes. i tried but it doesn’t work.

Reason is this. So by default ENABLE_XMPP_WEBSOCKET is enabled and hence it uses authentication = "token" and skips authentication = "anonymous" check.

The reason for doing the above thing is here

So It seems that unless you set ENABLE_XMPP_WEBSOCKET=0 then only you can use authentication = "anonymous"