With authentication, host is not seen by guest

Hello,
I have installed last year jitsi with authentication. On a Linux Debian server, I have the following packages :
rayleigh:[~] > dpkg-query -l | grep jitsi
ii jitsi-meet 2.0.5390-3 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.4628-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-web 1.0.4628-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.4628-1 all Configuration for web serving of Jitsi Meet
rc jitsi-videobridge 1126-1 amd64 WebRTC compatible Selective Forwarding Unit (SFU)
ii jitsi-videobridge2 2.1-416-g2f43d1b4-1 all WebRTC compatible Selective Forwarding Unit (SFU)
and of course jicofo (1.0-692-hf-1) and prosody (0.11.8-1).

Jitsi runs as expected. Host (H) can initialize a meeting and when host is connected, guests (G1 and G2) are able to connect to meeting with password.

Problem I cannot solve :

  • H sees G1 and G2 ;
  • G1 sees G2 but not H;
  • G2 sees G1 but not H.

But:

  • H can send message to G1 or G2.

I don’t understand why guest don’t see host and I don’t find config option to authorize guest to see host. I do my test on the same LAN and there is no firewall between both workstations and server.

Help will be welcome,

JKB

This is a stab in the dark, but did you happen to add the H user to the list of admins in your prosody config?

The reason I’m asking is because that scenario sounds a lot like how the UI would behave on a login by jibri user. In other words, H appears to be treated like a hidden user which would be the case for a recorder or focus user.

Of course, host user is in admin prosody list.

host is focus@auth.jitsi.systella.fr.
guest are xxx@jitsi.systella.fr

and my prosody config file is :

consider_bosh_secure = true;
https_key = "/etc/prosody/certs/jitsi.systella.fr.key";
https_certificate = "/etc/prosody/certs/jitsi.systella.fr.crt";

VirtualHost "jitsi.systella.fr"
    authentication = "internal_plain"
    ssl = {
            key = "/etc/prosody/certs/jitsi.systella.fr.key";
            certificate = "/etc/prosody/certs/jitsi.systella.fr.crt";
    }
    modules_enabled = {
        "bosh";
        "pubsub";
        "ping"; -- Enable mod_ping
    }
    c2s_require_encryption = false

VirtualHost "guest.jitsi.systella.fr"
    authentication = "internal_plain"
    c2s_require_encryption = false

Component "conference.jitsi.systella.fr" "muc"
     storage = "memory"

admins = { "focus@auth.jitsi.systella.fr" }

Component "jitsi-videobridge.jitsi.systella.fr"
    component_secret = "..."

VirtualHost "auth.jitsi.systella.fr"
    ssl = {
        key = "/etc/prosody/certs/jitsi.systella.fr.key";
        certificate = "/etc/prosody/certs/jitsi.systella.fr.crt";
    }
    authentication = "internal_plain"

Component "focus.jitsi.systella.fr"
    component_secret = "..."

Component "internal.auth.jitsi.systella.fr" "muc"
    storage = "memory"
    modules_enabled = { "ping"; }
    admins = { "focus@auth.jitsi.systella.fr", "jvb@auth.jitsi.systella.fr" }

That’s probably the cause of your problem. “focus” is the user used by jicofo and will be hidden by default. You should be using a different user for your admin users to log in.

Visibility on UI aside, you may end up with other issues by using “focus” as a login user. You’ll find that several prosody modules have hardcoded assumptions re that username and will treat it differently.

For example, “focus” user is excluded from speakerstats:

Thanks a lot, it now runs as expected.

Best regards,

JKB