Windows 10: open documents not listed under "Application window"

I am using Windows 10 and Microsoft Edge (v83.0.) to connect to Jitsi Meet. When I select Screen Share, it shows 3 tabs - “Your entire screen”, “Application window” and “Microsoft Edge tab”. But the Application window is not listing any of the opened documents - PDF, Word, Textpad etc, even when they are maximised. When I try the same in Windows 8 (Edge v81.0.), all open documents get listed in Application window. They show up when a document is maximised and disappear from list when that document is minimised. Works fine on Windows 8.
Please let me know what might be the reason for this issue in Windows 10, is this a bug or some settings in Windows 10 that I need to do ? Appreciate your help.