Why would audio lag behind the video?

I’m using the latest Docker containers which already seem to include the videobridge2, but I still get audio lags.

Do you have enableLipSync: false in your config.js?

1 Like

The enableLipSync settings is commented out in the default Docker config.js. What is the default value of this setting? Should I try to turn it off?

On meet.jit.si enableLipSync is explicitly set to false, otherwise by default it is true.

1 Like

We had changed that in latest packages soon that will be in stable. Will be off by default as it may cause issues

4 Likes

Ok @damencho , thanks to you and all Jitsi team! :wink:

1 Like

Hi, do you mean best to keep enableLipSync as false? Current using stable release from Apr 3rd.

What about Opus as potential source of latency problems? I just read that Opus uses high CPU: https://de.slideshare.net/Digium/getting-the-best-out-of-webrtc

I managed to upgrade to JVB2 on Ubuntu 18.04 with:

root@meeting:~# apt remove jitsi-videobridge
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  jicofo jitsi-meet jitsi-meet-prosody jitsi-meet-web jitsi-meet-web-config jitsi-videobridge2
Recommended packages:
  jitsi-meet-turnserver | apache2
The following packages will be REMOVED:
  jitsi-videobridge
The following NEW packages will be installed:
  jitsi-videobridge2
The following packages will be upgraded:
  jicofo jitsi-meet jitsi-meet-prosody jitsi-meet-web jitsi-meet-web-config
5 upgraded, 1 newly installed, 1 to remove and 48 not upgraded.
Need to get 69.9 MB of archives.
After this operation, 3,743 kB of additional disk space will be used.
Do you want to continue? [Y/n]

By removing jvb1 apt installed jvb2

Thank a lot for that information!
We a using now JVB2 and experiencing some issues like that and with audio.
Will try to disable lip sync

I’ve upgraded one of our installation to JVB2 but the video/audio lag is still present! What it’s weird it doesn’t happen with all clients. We were just three, 2xMac+Chrome and 1xWin+Firefox. Just one of the Mac client was lagging, even after reloading the webpage. It slightly improved during the conversation, could be from 2s to 1/1.5, but remained out of sync.

We’re currently using the config below to try to improve.

        resolution: 480,
        maxFps: 5,
        constraints: {
                video: {
                        aspectRatio: 16 / 9,
                        frameRate: 15,
                        height: {
                                ideal: 480,
                                max: 480,
                                min: 240
                        }
                }
        },

I’m curious if clients who are having this problem on MacOS with Chrome find that the Chromium browser works better. @Maxxer, or anyone else who has had this issue, would you be willing to give it a try? Thanks.

Hi. The issue was so annoying that we had to find a solution. Indeed migration to a new server with a brand new installation with JVB2 seems to have mitigated it, so (luckily for me and my customer) I’m not able to repro the issue anymore. Or at least I haven’t heard back from them since the upgrade, so I hope it’s not happening anymore.

1 Like