Why would audio lag behind the video?

Has anybody ever heard of this?

I’m totally new to Jitsi so pardon my ignorance, but I tried my first video call with one other person and I would see the person speak and then a couple seconds later hear the audio.

Maybe it has to do with the speed of sound versus the speed of light? :laughing:

My conferencing partner said that my speech seemed to be synced just fine.
We were using meet.jit.si. I am using Chromium (Debian GNU/Linux) and my partner was using Chrome (MacOS).

Could it have to do with the fact that I don’t use PulseAudio? (I would think using ALSA directly would have been faster.)

The only other factor was that my partner on the other end had a spotty network connection, but that doesn’t explain anything unless Jitsi’s handling of low bandwidth situations is to delay the audio. (Which I highly doubt.)

3 Likes

Bad network explains lipsync issues, its the nature of traffic, small but a lot of packets for audio and big packets for video with retransmissions for lost packets/frames … And you get lipsync issues …

1 Like

Okay, that makes sense for why video would lag behind audio: big packets (video) would take longer to retransmit and would be more likely to have errors and require multiple attempts.

But that’s not what I was experiencing. The video was coming in on time, but the audio was delayed by a couple seconds. It was so odd, it seemed like I must be doing something blatantly wrong. I tried it a second time with the same partner (with the lossy connection) and it happened again.

If you’ve never seen this problem, then I’m going to chalk it up to not using PulseAudio. Thanks.

Seeing the same problem with our own deployment, where we see lags in Audio while video is perfect? Is there any tips on ways to tune to ensure audio has the priority during call as our application is in the music domain?

You wouldn’t happen to be using a setup similar to mine (GNU/Linux with ALSA, no PulseAudio), would you?

Mine is out of the box config, in fact just realise there is something on ALSA or PulseAudio haha. We ran our own Jitsi server on Ubuntu/AWS, and mainly connected via React Native App. Normally connection is good, and we enable P2P as well. But occasionally we have users who experienced severe Audio Lag (imagine seeing the finger moved, then a few seconds later, that sound of notes only came through). Looking for ways to optimise the sound and trying to avoid sound distortion as well.

First of all thanks to the jitsi dev team for their hard work.
We have similar experience here. Default installation on Ubuntu. Video comes well, audio sometimes lags 2-3 seconds behind. And that lag varies all the time. Our tests show this is not dependent on whether wifi or ethernet cable used for connection. Also, happens with 2, 3, 4 or more participants. One would assume video would lag more often, but here the audio is getting behind.

Thank you for the support!

1 Like

I experience the same problem. Video is on time, audio is sometimes delayed up to 2 seconds. It fixes itself and then occures again.
All clients connected with LAN with fast connection, server is near.

Edit: all clients using Chrome on Win10

Edit2: just to make it more clear. As one of the participants is my flat mate, I hear him though the wall. So I can confirm, there is no delay on the video, it’s really just the audio.

1 Like

Hi,
I have experienced the same - but only with partners using MacOS with Chrome. Video/Audio not synchronous, audio 1-2 seconds behind.
Could be just coincidence, of course, but at least with me it has so far only occurred in this combination.
Anyhow, after a few minutes you are used in it… :upside_down_face:

1 Like

I can confirm that that was the case for both of the people I have had that problem with: MacOS with Chrome on their end, video is on time but audio lags.

Also, I have ruled out PulseAudio as a factor on my end.

Hello we just installed an instance and got it rolling. We are having the same problem on macbook are with M3 processor. Latest Chrome If I move over to a Microsoft surface on the same network 120down and 22 up only me on the network. The video quality on the mac is much worse and voice and video are not in sync. If I switch to the surface it’s perfect!

1 Like

I also had this problem on a mac with Chrome with about 6 people connected, but I didn’t try it on a windows machine. I have a 1 gigabit fiber internet connection and a server with a Xeon processor with 24 cores that run’s Jitsi. Any ideas what could cause this problem?

What sort of a network was the Mac on? I’m not sure, but I think that both of the people who had the video-in-sync, audio-lagging bug that I spoke with were on iffy networks and may have been dropping packets.

@beninseattle My mac was on and near my Ubiquitt wifi which should be good enough for video streams and the server is in the same network. I don’t really know what the other participants used. But my experience was that with 4+ participants the audio and video from all participants was delayed. After some disconnected it got better again. Is it possible that one bad connection affects all the other connections too?

I also just found the Jitsi torture test project which has a lip sync test: https://github.com/jitsi/jitsi-meet-torture
I managed to get most of those tests to run, but just the LipSyncTest ran into a problem. (java.lang.IndexOutOfBoundsException: Index 0 out of bounds for length 0) I will try to fix this problem. Maybe this would give me some indication if my server is running correctly. I also use a second reverse proxy and I don’t know if I forwarded everything correctly.

Same problem here with Windows 10 PCs + Chrome 80.0.3987.149. :confused:

2 Likes

We installed Jitsi Meet deployment on two own servers, one with token authentication and the other with anonymous authentication. Both are being tested and are proving successfully. The only current problem is the desynchronization between audio and video after a few minutes of the conference, experimented above all on Chrome (v.80) for Windows 10. What happens is exactly described in this issue: so audio arrives 2-3 sec. after video. I would like to ask:.

  1. With JitsiVideoBridge2 now stable declared, are there any improvements in the lipsync management?
  2. We have run tests with enable-lipsync both at true and false but we have not found big differences, however do you recommend to enable or disable this option?
  3. Are there other parameters in JitsiMeet Web’s config.js file that can affect audio and video synchronization?

Thanks for your kind support.

1 Like

Thanks for the deep analysis, indeed I’d also like to know if there are config params which could improve the situation.
Someone opened an issue on GitHub about failing LipSync test (maybe it was you).

Edit: other info from a dev here, not really recent stuff but the more recent I could find:

Back to you original question, lip sync is broken currently because of the way we rewrite timestamps […]. Unfortunately we don’t have a good solution to that problem, we need to find the time to simplify our timestamp rewriting.

Ok, thanks to you. I didn’t open the issue on GitHub, but I got the same error, using jitsi-meet-torture for LipSync Test, while it works for other tests.
I found little improvements about audio-video sync, reducing resolution and video constraints on config.js in jitsi-meet-web .

We also got improvements by reducing FPS, but we’re still getting audio ~2s behind video rather often. If anyone has suggestions they’re welcome

Hi, we found a great improvement in audio/video sync upgrading from JVB 1.0 to JVB 2.0, now declared stable. This release was already installed in meet.jit.si since few months.

1 Like