Where is the lobby after the update 011221?

Hi,
i just updated my Server on a Debian10 stable.
After that the lobby feature dissapeared.
How can i bring it back?
tia
jay

What is your prosody config?

which of them?
prosody.cfg.lua?
localhost.cfg.lua?
video.mydomain.com.cfg.lua?

This one:

Its the same as before the update:

plugin_paths = { “/usr/share/jitsi-meet/prosody-plugins/” }

– domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = “video.esample.com”;

turncredentials_secret = “xxxxxxxxxxxxxxxxx”;

turncredentials = {
{ type = “stun”, host = “video.esample.com”, port = “3478” },
{ type = “turn”, host = “video.esample.com”, port = “3478”, transport = “udp” },
{ type = “turns”, host = “video.esample.com”, port = “443”, transport = “tcp” }
};

cross_domain_bosh = false;
consider_bosh_secure = true;
– https_ports = { }; – Remove this line to prevent listening on port 5284

Mozilla SSL Configuration Generator
ssl = {
protocol = “tlsv1_2+”;
ciphers = “ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384”
}

VirtualHost “video.esample.com
– enabled = false – Remove this line to enable this host
– authentication = “internal_plain”
authentication = “internal_hashed”
– “internal_hashed” neu
– Properties below are modified by jitsi-meet-tokens package config
– and authentication above is switched to “token”
–app_id=“example_app_id”
–app_secret=“example_app_secret”
– Assign this host a certificate for TLS, otherwise it would use the one
– set in the global section (if any).
– Note that old-style SSL on port 5223 only supports one certificate, and will always
– use the global one.
ssl = {
key = “/etc/prosody/certs/video.esample.com.key”;
certificate = “/etc/prosody/certs/video.esample.com.crt”;
}
speakerstats_component = “speakerstats.video.esample.com
conference_duration_component = “conferenceduration.video.esample.com
– we need bosh
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
“speakerstats”;
“turncredentials”;
“conference_duration”;
}
c2s_require_encryption = false
main_muc = “conference.video.esample.com
– muc_lobby_whitelist = { “recorder.video.esample.com” } – Here we can whitelist jibri to enter lobby enabled rooms

VirtualHost “guest.video.esample.com
authentication = “anonymous”
ssl = {
key = “/etc/prosody/certs/auth.video.esample.com.key”;
certificate = “/etc/prosody/certs/auth.video.esample.com.crt”;
}
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
“speakerstats”;
“turncredentials”;
“conference_duration”;
“muc_lobby_rooms”;
}
c2s_require_encryption = false
lobby_muc = “lobby.video.esample.com
main_muc = “conference.video.esample.com
muc_lobby_whitelist = { “recorder.video.esample.com” } – Here we can whitelist jibri to enter lobby enabled roo$

Component “conference.video.esample.com” “muc”
storage = “memory”
modules_enabled = {
“muc_meeting_id”;
“muc_domain_mapper”;
– “token_verification”;
}
admins = { “focus@auth.video.esample.com” }
muc_room_locking = false
muc_room_default_public_jids = true

– internal muc component
Component “internal.auth.video.esample.com” “muc”
storage = “memory”
modules_enabled = {
“ping”;
}
admins = { “focus@auth.video.esample.com”, “jvb@auth.video.esample.com” }
muc_room_locking = false
muc_room_default_public_jids = true

VirtualHost “auth.video.esample.com
ssl = {
key = “/etc/prosody/certs/auth.video.esample.com.key”;
certificate = “/etc/prosody/certs/auth.video.esample.com.crt”;
}
authentication = “internal_plain”

Component “focus.video.esample.com
component_secret = “xxxxxxx”

Component “speakerstats.video.esample.com” “speakerstats_component”
muc_component = “conference.video.esample.com

Component “conferenceduration.video.esample.com” “conference_duration_component”
muc_component = “conference.video.esample.com

Component “lobby.video.esample.com” “muc”
storage = “memory”
restrict_room_creation = true
muc_room_locking = false
muc_room_default_public_jids = true

– internal muc component, meant to enable pools of jibri and jigasi clients
Component “internal.auth.video.esample.com” “muc”
modules_enabled = {
“ping”;
}
storage = “memory”
muc_room_cache_size = 1000

VirtualHost “recorder.video.esample.com
modules_enabled = {
“ping”;
}
authentication = “internal_plain”

That needs to be under VirtualHost “video.esample.com” not under VirtualHost “guest.video.esample.com”, as it is in the template/default config: jitsi-meet/prosody.cfg.lua-jvb.example at 5ef60c3a7d6175169dec7fbb1e1aff729b2e3019 · jitsi/jitsi-meet · GitHub

If i change that, the Lobby disappears in the old system.
shouldnt it be the same config in both versions?

The config should be as the template. There was a problem where you need to move it with the old versions in order to make it work, and that was fixed. And this was only a problem when using anonymous domain, and that bug was fixed.

Ok.
Did i get it correct that i have to use the old config with the old version and have to change it after the update?
The template is not clearly, because it has no guest virtualhost…

There is no need to enable any module under guest account.

hello