When Trying to update jitsi I get an error

root@connect ~ # apt-get install jibri
Reading package lists... Done
Building dependency tree       
Reading state information... Done
jibri is already the newest version (8.0-61-g99288dc-1).
The following packages were automatically installed and are no longer required:
  libevent-core-2.1-7 libevent-extra-2.1-7 libevent-openssl-2.1-7
  libevent-pthreads-2.1-7 libmysqlclient21 linux-headers-5.4.0-70
  linux-headers-5.4.0-70-generic linux-image-5.4.0-70-generic
  linux-modules-5.4.0-70-generic linux-modules-extra-5.4.0-70-generic
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up initramfs-tools (0.136ubuntu6.4) ...
update-initramfs: deferring update (trigger activated)
Setting up linux-firmware (1.187.10) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-72-generic
Error 24 : Write error : cannot write compressed block 
E: mkinitramfs failure cpio 141 lz4 -9 -l 24
update-initramfs: failed for /boot/initrd.img-5.4.0-72-generic with 1.
dpkg: error processing package linux-firmware (--configure):
 installed linux-firmware package post-installation script subprocess returned error exit status 1
Processing triggers for initramfs-tools (0.136ubuntu6.4) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-72-generic
Error 24 : Write error : cannot write compressed block 
E: mkinitramfs failure cpio 141 lz4 -9 -l 24
update-initramfs: failed for /boot/initrd.img-5.4.0-72-generic with 1.
dpkg: error processing package initramfs-tools (--configure):
 installed initramfs-tools package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 linux-firmware
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)

could anyone help? thanks!

@Freddie

I don’t understand: the command shows you’re trying to install Jibri.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
root@connect ~ # sudo apt update && sudo apt upgrade -y
Hit:1 https://deb.nodesource.com/node_12.x focal InRelease
Hit:2 http://security.ubuntu.com/ubuntu focal-security InRelease                  
Hit:3 https://dl.yarnpkg.com/debian stable InRelease                              
Get:4 https://mega.nz/linux/MEGAsync/xUbuntu_20.04 ./ InRelease [2,441 B]         
Hit:5 http://us.archive.ubuntu.com/ubuntu focal InRelease                         
Hit:6 http://repo.zabbix.com/zabbix/5.3/ubuntu focal InRelease                    
Hit:7 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease         
Get:8 https://download.jitsi.org stable/ InRelease [1,882 B]              
Err:8 https://download.jitsi.org stable/ InRelease  
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B4D2D216F1FD7806
Fetched 2,441 B in 1s (2,769 B/s)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://repo.zabbix.com/zabbix/5.3/ubuntu focal InRelease' doesn't support architecture 'i386'
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://download.jitsi.org stable/ InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B4D2D216F1FD7806
W: Failed to fetch https://download.jitsi.org/stable/InRelease  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B4D2D216F1FD7806
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libevent-core-2.1-7 libevent-extra-2.1-7 libevent-openssl-2.1-7
  libevent-pthreads-2.1-7 libmysqlclient21 linux-headers-5.4.0-70
  linux-headers-5.4.0-70-generic linux-image-5.4.0-70-generic
  linux-modules-5.4.0-70-generic linux-modules-extra-5.4.0-70-generic
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up initramfs-tools (0.136ubuntu6.4) ...
update-initramfs: deferring update (trigger activated)
Setting up linux-firmware (1.187.10) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-72-generic
Error 24 : Write error : cannot write compressed block 
E: mkinitramfs failure cpio 141 lz4 -9 -l 24
update-initramfs: failed for /boot/initrd.img-5.4.0-72-generic with 1.
dpkg: error processing package linux-firmware (--configure):
 installed linux-firmware package post-installation script subprocess returned error exit status 1
Processing triggers for initramfs-tools (0.136ubuntu6.4) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-72-generic
Error 24 : Write error : cannot write compressed block 
E: mkinitramfs failure cpio 141 lz4 -9 -l 24
update-initramfs: failed for /boot/initrd.img-5.4.0-72-generic with 1.
dpkg: error processing package initramfs-tools (--configure):
 installed initramfs-tools package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 linux-firmware
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@connect ~ # 

There’s been a gpg key change. Use this command to get the new key:

wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | apt-key add -

1 Like

thanks, i ran: wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | apt-key add -; sudo apt autoremove; sudo apt update && sudo apt upgrade to fix it. works like a charm now

You are getting problem with other packages …

Thank you, i would have the same problem.
With your solution i fix it.