When sharing screen to several users it looks black using Chrome

I have an inconvenience. From the Chrome browser, if I share the full screen with the rest of the guests in the room, they tell me that they do not see what I share, they only see a black screen, however, from another browser such as Firefox, it allows it to be done without a problem.

What are the browser version and os and version you use?
Is this on meet.jit.si?

Hello. I want to clarify that I have the jitsi meet service hosted on my own server, but I did the test on a Chrome browser Version 103.0.5060.134 (Official Build) (64 bits), the operating system I use is Ubuntu, but the same I think the problem happens on any browser of any operating system.
the site where it is hosted is this https://meet.knowark.com/

Can that be from your hosting what is the available bandwidth there, upload and download?
Do you reproduce on meet.jit.si?

If I run https://meet.jit.si/ I have no problem, it can be shared in any browser. If you like, you can try the link that I share just to test the problem that occurs.
https://meet.knowark.com/

I tried with 3 participants and it worked with no problem.

What is the size of the screen you share? What if you share a window with a similar size? What happens if you share a window with a smaller size?
Mind that with some display servers under Linux such issues are known(especially wayland), that’s why I asked about the operating system.

The problem occurs after I share and stop sharing the screen, but then I want to share the screen again to other users, the screen is black and does not let you see what is being shared.

Your websockets are not working.

2022-10-20T18:07:13.048Z [modules/RTC/BridgeChannel.js] <e.onclose>:  Channel closed: 1006 
r @ Logger.js:154
e.onclose @ BridgeChannel.js:433
BridgeChannel.js:84 WebSocket connection to 'wss://meet.knowark.com/colibri-ws/default-id/4d1f6234bbf69a78/34be3792?pwd=61ua8r3n4c1vc4aj910bftlb3l' failed: 

Check your nginx configs do you have this rule

I ask you something. Should I put that as you show it there or should I modify it my way?

If you are missing you need to have it.
Follow 3., 4. and 5. from here: FAQ | Jitsi Meet

Hello. Put the configuration that you told me in the nginx as it told me in the following way.

Do you have a way to connect through anydesk and see if you can give my server a review to see what else it could be.

Have you restarted both services?

Yes, reseted all services.

Check nginx and jvb logs for errors. Do you see jvb listening on that port?

Something else responds, this is not Jitsi

curl 'https://your-site-address/colibri-ws/default-id/someid'
                                                       
<!doctype html>
<title>Site Maintenance</title>
<style>
  body { text-align: center; padding: 150px; }
  h1 { font-size: 50px; }
  body { font: 20px Helvetica, sans-serif; color: #333; }
  article { display: block; text-align: left; width: 650px; margin: 0 auto; }
  a { color: #dc8100; text-decoration: none; }
  a:hover { color: #333; text-decoration: none; }
</style>

<article>
    <h1>We&rsquo;ll be back soon!</h1>
    <div>
        <p>Sorry for the inconvenience but we&rsquo;re performing some maintenance at the moment, otherwise we&rsquo;ll be back online shortly!</p>
1 Like

I don’t understand what you mean with that message, could you explain better what you mean by that?

@emrah means that your nginx is not correctly configured. If you hit that URL you need to reach out to jvb jetty, instead, you get some maintenance page from nginx …

If I use your server to check as @emrah pointed I get:

curl -v "https://meet.your.domain.com/colibri-ws/default-id"  2>&1 | grep "Server:"
< Server: nginx/1.18.0 (Ubuntu)

If I try it on some jvb from meet.jit.si:

curl -v "https://somejvbfrommeet.jitsi.net/colibri-ws/default-id" 2>&1 | grep "Server:"
< Server: Jetty(11.0.10)

According to what you say, what action should I take to be able to make the screen sharing option work in Chrome and not turn out black for the other participants.