When i use invite link in the meeting , the user need jwt to join , how can i solve this

i use react sdk in my app , and when i copied the invite link of the meeting , he asks for user name and password , because the link does not contain jwt , so how can i solve this ??

You can use jitsi-meet/config.js at 43b3db11e001ddc92b9636858e4bcbd35eef6852 · jitsi/jitsi-meet · GitHub to put your invite link where you will ask the user for authentication and will generate the jwt token and embed jitsi-meet opened with that token.

you mean , i must ask the user for authentication (username and password of the server ) , ??
and if yes , there is not any other method ?

Depends on you, you can create jwt without authentication of the user.

photo_2023-01-16_11-15-46
what should i do if i want to change the link of invite ?

i tried to overwrite this key (inviteDomain ) like this ::
configOverwrite: {inviteDomain:‘www.google.com’}
but it does not work

I don’t think you can override that option. You can directly set it in your server’s config.js though.

How can i directly set it in ,my server’s config.js ? Could you please give me code example

Edit the file in /etc/jitsi/meet/*-config.js

i tried to edit in that
{
// The domain url to apply (will replace the domain in the sharing conference link/embed section)
inviteDomain: 'example-company.org,
// The hex value for the colour used as background }
but it does not work

If you add

enable_domain_verification = false
in
/etc/prosody/prosody.cfg.lua

a guest user may join the room without a token.