When I enter a room everyone Is muted / with no video for me

Hello, for a couple years I’ve been able to follow my school courses online (via Android app) without any trouble. Yesterday I entered the online room as always, but the lesson started and I couldn’t see nor hear the teacher, nor any of the other partecipants. All I could see were their icons, but with no video and their audio seemed disabled. I was the only one to experience that issue.
Last week everything worked all right and I didn’t change any setting on my phone; I tried using a tablet, same issue. I checked the app permissions and my internet connection, everything was fine. Eventually I was able to follow the lesson via browser but after some time the issue came back.
A couple hours later I tried to enter another room, not the school’s one, and everything worked again. So today I went to school and tried to enter the lesson online, but I still had the same issue: everybody but me could see and hear the teacher, for me everybody was just an icon with audio and video disabled.
How can I fix this problem in order to be able to follow my lessons?

Is this on meet.jit.si? What version of the app do you use?

Hi, thanks for your reply! The app version is 22.7.1.
I don’t think it’s on meet.jit.si, but hosted on the school’s domain (Is this a thing? I don’t know Jitsi apart for following my lessons)

Yep, it can be some problem after an update or not running the latest version.
What version of jitsi-meet runs there and what does config.js look like on that deployment? Was it recently updated? These are some questions that may shed some light on the problem.