What should be in nginx.conf?

I have Jitsi-Meet installed, but can’t access it from the internet. running nginx -T provided the listing below. It is clearly not correct. What should it look like? If anyone can provide me with a sanitised copy of their result I would greatly appreciate it.

configuration file /etc/nginx/conf.d/default.conf:

server {
listen 80;
server_name localhost;

#charset koi8-r;
#access_log  /var/log/nginx/host.access.log  main;

location / {
    root   /usr/share/nginx/html;
    index  index.html index.htm;
}

#error_page  404              /404.html;

# redirect server error pages to the static page /50x.html
#
error_page   500 502 503 504  /50x.html;
location = /50x.html {
    root   /usr/share/nginx/html;
}

# proxy the PHP scripts to Apache listening on 127.0.0.1:80
#
#location ~ \.php$ {
#    proxy_pass   http://127.0.0.1;
#}

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
#
#location ~ \.php$ {
#    root           html;
#    fastcgi_pass   127.0.0.1:9000;
#    fastcgi_index  index.php;
#    fastcgi_param  SCRIPT_FILENAME  /scripts$fastcgi_script_name;
#    include        fastcgi_params;
#}

# deny access to .htaccess files, if Apache's document root
# concurs with nginx's one
#
#location ~ /\.ht {
#    deny  all;
#}

}

I found that the last line of the /etc/nginx/nginx.conf file was incorrect.

I changed the last line as follows and things now appear to work.
# include /etc/nginx/conf.d/.conf;
include /etc/nginx/sites-enabled/
.conf;

I won’t reproduce the changes, but they now appear correct when displayed with nginx -T.
nginx -s reload activated the changes.

thats just a default configuration,
your real jitsi configuration file should be under: /etc/nginx/sites-available … YourDomain.conf
have you installed nginx before you did install jitsi, like mentioned on the Quick Install tutorial?

is your server behind a NAT, FIREWALL or something else?
or can you be more detailed about your current server setup?

m_aeiou, thanks for replying. I am using a dedicated server with nothing else on it. It is not behind a firewall. The ip is 176.74.16.22 and the subdomain name is jitsi.meetu3adacorum.org.
After three weeks of hard work installing and reinstalling every way possible, it now works. On Ubuntu nothing appears to use conf.d. It was only after changing nginx.conf as described above that it worked.

I now have to harden it and put in access passwords to open rooms.

good to hear that you solved the problem :wink: … and enjoy jitsi

i should refresh page next time before the final post ^^