What is the recommend Java version

What is the recommend Java version ?

My virtual environment

  • VMware ESX 6
  • Debian 10
  • 16x vCPU
  • 16 GB RAM
  • 1Gbps network

Installed: openjdk-11-jre-headless:amd64 11.0.6+10-1~deb10u1

Thanks.

Regards,
Petr Kallen

Java 8 is what the current bridge is optimised for.

1 Like

Why this Java 8 dependency is not automatically solved in Debian 10 using apt repository ? As default, openjdk-11-jre-headless:amd64 11.0.6+10-1~deb10u1 is installed by jitsi-meet needs… When I manually remove Java 11 and install Java 8 following this guide, https://linuxize.com/post/install-java-on-debian-10/ Jitsi stop works. Web interface is accessible, but no video and no audio.

It seems that it’s necessary to add a certificate from Prosody to the Java environment.

Still the same for videobridge2?

with

git checkout stable/jitsi-meet_4548

checking

grep version ./.github/workflows/maven.yml
        java-version: 1.8

is that in fact still the case for JVB2/stable?
no jdk11 support as yet?

It supports java11, will run normally. It is just not optimized for it, this is something we will do when time permits.

ok, that’s @ runtime

for build … jdk11 as well? or just jdk8?