What I port I have to Configure?

Hello,
I’m configuring the jitsi server in a ubuntu virtual machine. I can use it localy, but i want to use it outside my network. I have configured in my router the port forwarding for the 80 port (http), but it appears the nginx server.
ngix
What configuration I have to change for working it??
Thanks.

You need forward also the port 443 for https.

I have configured in the router the forwarding for de port 443 and it give an error.
not found router

It sais that it doesn’t work.

both ports should be forwarded, can you share your nginx configuration?

Nginx configuration
user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
worker_connections 768;
# multi_accept on;
}

http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

Basic Settings

    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    ##
    # SSL Settings
    ##

    ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
    ssl_prefer_server_ciphers on;

    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;

    
    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+r$

    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;

I should have to change here something??
Is my first time configuring a jitsi server.
Thanks.

the nginx is ok.

go to ```
/etc/nginx/sites-enabled/youdomain…conf and print it

the configuration of your jitsi is there.

when you forward the ports, extranl and internal ports should be the same (443)

image
I should change the 80 and 4444 to 443??

the 80 is ok, keep it and replace 4444 by 443.

or if you want yo keep 4444, in your url type like this:
https://yourPublicIP:4444, and forward this port also.