Welcome Page welcome-footer-about not seems to work

hello all,
I have a self-hosted Jitsi installation on Debian 9.1 with the following Jitsi packages installed.
jicofo 1.0-690-1
jitsi-meet 2.0.5390-1
jitsi-meet-prosody 1.0.4628-1
jitsi-meet-web 1.0.4628-1
jitsi-meet-web-config 1.0.4628-1
jitsi-videobridge2 2.1-416-g2f43d1b4-1
So far Jitsi works great.

However, yesterday and today I tried to adjust the footer as described by Damencho.
I have the contents of both files static/welcomePageAdditionalContent.html:

<template id = "welcome-page-additional-content-template">
<div class="welcome-page-content">
    <div class="welcome-footer">
        <div class="welcome-footer-content">
            <div class="welcome-footer-about">
                <div>
                    <a href="https://www.khi.fi.it/" rel="noopener" target="_blank">Provided by Kunsthistorisches Institut</a> | <a href="https://www.khi.fi.it/en/impressum.php/" rel="noopener" target="_blank">imprint</a> | <a href="https://www.khi.fi.it/en/datenschutz.php/" rel="noopener" target="_blank">Privacy Policy</a>
                </div>
            </div>
        </div>
    </div>
</div>

plugin.head.html

<style>
.welcome-page-content {
    display: flex;
    flex-direction: column;
    flex-grow: 1;
    justify-content: space-between;
    position: relative;
    z-index: 1;
    margin-top: 35px;
    width: 100%
}
.welcome-page-content .welcome-footer {
    color: #FFF;
    display: flex;
    padding-bottom: 20px;
    padding-top: 20px;
    width: 100%;
    z-index: 1
}
.welcome-page-content .welcome-footer-content a {
    color: #fff !important;
    text-decoration: underline
}

.welcome-page-content .welcome-footer-content {
    display: flex;
    justify-content: center;
    width: 100%;
    z-index: 2
}

.welcome-page-content .welcome-footer-about {
    display: flex;
    flex-direction: column;
    flex: 1;
    font-size: 14px;
    line-height: 20px;
    text-align: center;
    justify-content: center
}


.welcome-page-content .welcome-footer-about:last-child {
    margin-left: 4px
}

In interface.config.js I adjusted the value DISPLAY_WELCOME_PAGE_CONTENT: true, .
The changes were not applied.
Only when I adjust the base.html a footer is shown.
base.html:

<base href="/" /> <template id = "welcome-page-additional-content-template">
<div class="welcome-page-content">
    <div class="welcome-footer">
        <div class="welcome-footer-content">
            <div class="welcome-footer-about">
                <div>
                    <a href="https://www.khi.fi.it/" rel="noopener" target="_blank">Provided by Kunsthistorisches Institut</a> | <a href="https://www.khi.fi.it/en/impressum.php/" rel="noopener" target="_blank">Imprint</a> | <a href="https://www.khi.fi.it/en/datenschutz.php/" rel="noopener" target="_blank">Privacy Policy</a>
                </div>
            </div>
        </div>
    </div>
</div>

I am also not really fit in css and html so my question

Did I do something wrong or is this a bug?
Best ,
Michael

We also upgraded to 1.0.4628-1 and are seeing the same thing. Seems like a bug to me.

Also seems like the “start muted” does no longer work.

This wasn’t a great release/upgrade.

looking into customizing as well. do you mind linking were damencho described the process (even if not worky currently?) -> i failed to find it :blush: (found: Welcome Page Additional Content - #6 by damencho )

also, maybe you are simply missing the at the “template id” / “welcomePageAdditionalContent.html” ?

hmm also, setting DISPLAY_WELCOME_FOOTER to false will break the previous conferences postion box

for me the templates work, but it destroys the layout of most boxes and whatnot, will toy around but my knowledge of css is rather lacking …

but for your problem, i think you may have only forgetting the terminating /template

also in the past i could change the welcome text by modifying the respective .json files -> this seems removed? doing things in there now as no effect anymore? -> needs to be modified before transpiling now?

Hello snek,
I’m not sure what you mean with:

maybe you are simply missing the at the “template id” / “welcomePageAdditionalContent.html”

in the code section of my post you don’t see “</ template>” but I have it in the base.html and welcomePageAdditionalContent.html
Best,
Michael

I didnt see it in your example, i added it below, not sure if that has any impact but it somewhat works for me (except borks all positions now)
i added the at your example below

<template id = "welcome-page-additional-content-template">bla bla bla </template>

Thanks, I don’t know how to add it here but my files lookes exactly like your example.

well, your example ends with </div>, there should be an additional </template> after the last line. not sure if that has any impact though, try adding it.

I upgraded Jitsi-Meet and now I have the same problem.
Jitsi-Meet seems to work good, but the welcome page seems to be broken and empty (very different from the one in https://meet.jit.si/).
Hoping in news about it.
Thanks in advance.