Websocket url does not work meanwhile bosh url works

belows are the related config. https://jitsi.yzbabyu.com can not work if i use Websocket URL.
But It works well if i use BOSH URL. who knows the reason? jitsi does not support websocket yet?

 // BOSH URL. FIXME: use XEP-0156 to discover it.
//bosh: '//jitsi.yzbabyu.com/http-bind',

// Websocket URL
websocket: 'wss://jitsi.yzbabyu.com/xmpp-websocket',

    -- HTTP modules
            "bosh"; -- Enable BOSH clients, aka "Jabber over HTTP"
            "websocket"; -- XMPP over WebSockets
            "http_files"; -- Serve static files from a directory over HTTP

# xmpp websockets
location = /xmpp-websocket {
    proxy_pass http://127.0.0.1:5280/xmpp-websocket?prefix=$prefix&$args;
    proxy_http_version 1.1;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection "upgrade";
    proxy_set_header Host $http_host;
    tcp_nodelay on;
}

videobridge {
http-servers {
public {
port = 9090
}
}
websockets {
enabled = true
domain = “jitsi.yzbabyu.com:443
tls = true
}
}

Maybe related in Prosody version

root@jitsi:/# prosodyctl about
Prosody 0.11.8

Prosody directories

Data directory: /var/lib/prosody
Config directory: /etc/prosody
Source directory: /usr/lib/prosody
Plugin directories:
/usr/share/jitsi-meet/prosody-plugins/
/usr/lib/prosody/modules/

Lua environment

Lua version: Lua 5.2

Lua module search paths:
/usr/lib/prosody/?.lua
/usr/local/share/lua/5.2/?.lua
/usr/local/share/lua/5.2/?/init.lua
/usr/local/lib/lua/5.2/?.lua
/usr/local/lib/lua/5.2/?/init.lua
/usr/share/lua/5.2/?.lua
/usr/share/lua/5.2/?/init.lua

Lua C module search paths:
/usr/lib/prosody/?.so
/usr/local/lib/lua/5.2/?.so
/usr/lib/x86_64-linux-gnu/lua/5.2/?.so
/usr/lib/lua/5.2/?.so
/usr/local/lib/lua/5.2/loadall.so

LuaRocks: Not installed

Network

Backend: select

Lua module versions

lfs: LuaFileSystem 1.8.0
libevent: 2.1.12-stable
luaevent: 0.4.6
lxp: LuaExpat 1.3.0
socket: LuaSocket 3.0-rc1
ssl: 1.0

prosody latest version is 0.12.0 but I just installed 0.11.8. I will upgrade to 0.12.0 to check.

Don’t upgrade to 12. Current stable jitsi does not work well with that yet. Use latest 0.11, so 0.11.13.

0.11.8 is OK. Did you check the following topic:

There are two websockets that can be used. The one for /xmpp-websocket is for signalling. The other one /colibri is to communicate directly with the bridge.

I will study and test. Thank you.