Websocket is pointing at localhost

Hi,

We have deployed jitsi via helm on GKE/GCE and upgraded to the latest stable 5390-2. Everything started working after disabling the websocket : ENABLE_XMPP_WEBSOCKET: “0”
When we enable the websocket again, the jitsi plugin starts using websocket using :

wss://localhost:8443/xmpp-websocket?room=5eb1591ed

The websocket returns an error : Error in connection establishment: net::ERR_CONNECTION_REFUSED

The plugin is in a permanent disconnected state and tries to reload.

I am pretty sure the localhost in the url is the culprit and I expect that this should be the url of our meet server.

How should we set that url, and on which part of the installation ? (all services are split out in different pods), and if this assumption is wrong, what should we do ? The GKE cluster is websocket enabled (we are running other services with websockets so websockets work)

Thanks,
Robert

I have research a bit further and have found the following solution for the localhost :
PUBLIC_URL: meet.something.com
This has been added to all instances, but is needed for prosody and meet

After this the websocket gives a real error : Error during WebSocket handshake: Unexpected response code: 403

I will now close this issue and possibly create a new one for the new error

Thans anyway!