WebSocket connection to ... failed

Hello! I reread the forum, tried different options, but still did not solve the problem. I ask for help …
Disconnects from the room. Websocket error. How to solve this problem?


Is there a solution - Self-Hosting Guide - Docker · Jitsi Meet Handbook ?

Untill someone gives you a better answer, please check that you have equivelent web socket lines in your config (the below config is for Apache2)

    ProxyPreserveHost on
    ProxyPass /http-bind http://localhost:5280/http-bind
    ProxyPassReverse /http-bind http://localhost:5280/http-bind
    ProxyPass /xmpp-websocket ws://localhost:5280/xmpp-websocket
    ProxyPassReverse /xmpp-websocket ws://localhost:5280/xmpp-websocket
    ProxyPass /colibri-ws/default-id ws://localhost:9090/colibri-ws/default-id
    ProxyPassReverse /colibri-ws/default-id ws://localhost:9090/colibri-ws/default-id

@GeorgeJitsi this also happens on the jitsi community edition quite frequently now.

Seems like a bug in the meet.jitsi version.

I do not get these error messages. Jitsi just works, no issues.

Do you have this issue intermittently? or does it occur every time?

@GeorgeJitsi it has happened in 4 out of 5 sessions that we have hosted. In those sessions, it happened to multiple people during the session. In each session 5-6 participants (from around 10-20 per session) experienced this. The issue persisted over the last 3 weeks.

@GeorgeJitsi another note: this happens sporadically and hard to predict since it doesn’t happen to everybody, every time.

Those kinds of issues are always the most challenging.

I would suggest carefully monitoring the system where you can. The load on the server, bandwidth to and from the server. Network errors, etc.

Sadly I am not experience in the above as to advise how.

If your using a hosting provider, then you cannot monitor the load on the host on which your server is running.

I have had/heard about issues with faulty switches, and in an environment where network packets travel different paths at different times (routing), a faulty port on a switch can cause what appears to be intermittent issues.

I don’t know the reliability of each of the client’s who are connecting to your server, either.

While my server has little traffic, I can say I have never seen the issues you report, and I can say that the resources used by my jitsi instance is not overloaded in any area, plenty of spare resources, which hopefully helps.

The phrase “Data frame received after close”, sounds like a network [timing] issue, but others on the forum should be better suited to make such suggestions.

Are any of your users international? Think about the distances the packets have to travel, but since you did not mention this, I guess this is not the issue.

Are you able to use meet.jit.si to do a video conference and see if people still get the same issue? If you have a number of people who are willing to run tests with you, then set up scenarios using your own server and that of meet.jit.si, if errors only occur with your server, then you can be confident the issue is within your server and you can then focus there. All this is very time consuming. Today I spend two hours watching Youtube videos in a test meeting for a particular laptop (Debian XFCE client, using external webcam and Jabra 710 speakerphone, all running on battery power). This took longer to configure than I expected, after which test went well, but it took two hours. I am now satisfied with the performance and reliability of the laptop for taking to meetings so the next test will be using the laptop in a “real world” meeting.

I apologise, but “good luck” is all I can offer at this time…