Websocket connection to .... failed

You have made changes to nginx config from default one.

There is no port running on 9091 in your system. But in your nginx config you have 9091.

Just change whole colibri ws to block to sample given in the file.

Just check the sample one

@shawn @Freddie @Ashiq_Hassan
I am still getting those errors even after a fresh installation. This is my jvb.log .

And Nginx error log.

Start with uncustomized Nginx conf

Prosody version?

@emrah I uninstalled again and install with your script.[link].

checking the external IP...

>>> checking DNS record for mydomain.com...

>>> checking mydomain.com resolved IP...

>>> checking DNS record for turn.mydomain.com...

>>> Aborted! turn.mydomain.com is not resolvable on Internet
>>> Recommendation: Set DNS CNAME or A record for turn.mydomain.com on a public DNS

>>> Something went wrong. Not completed!

This is the final result.

0.11.10-1

1 Like

You need to set two FQDNs for your server. One for jitsi, the other for TURN
It seems that you didn’t set a valid TURN address

1 Like

@emrah Thanks for your valuable suggestion. I created a free dns and used it in "export TURN_HOST=turn.yourdomain.com " here. It works and everything was fine. Then I uninstalled jitsi meet and also run your “remove the old installation if exists” portion for a safe uninstall. Then we installed our desired version 5765 and the same problems appeared again. Video, Audio vanish after joining 3 participants.

This mostly happens when the clients cannot connect to JVB or when there is something wrong with JVB

@emrah but I didn’t change anything after installation. This is my installation command.

sudo apt install jitsi-videobridge2=2.1-478-gc6da57bd-1 jicofo=1.0-740-1 jitsi-meet-web=1.0.4900-1 jitsi-meet-web-config=1.0.4900-1 jitsi-meet-prosody=1.0.4900-1 jitsi-meet-turnserver=1.0.4900-1 jitsi-meet=2.0.5765-1

Can I install jitsi meet 5765 with your script?

Change this line

from

apt-get $APT_PROXY_OPTION -y --install-recommends install jitsi-meet

to

apt-get $APT_PROXY_OPTION -y --install-recommends install \
  jitsi-videobridge2=2.1-478-gc6da57bd-1 jicofo=1.0-740-1 \
  jitsi-meet-web=1.0.4900-1 jitsi-meet-web-config=1.0.4900-1 \
  jitsi-meet-prosody=1.0.4900-1 jitsi-meet-turnserver=1.0.4900-1 \
  jitsi-meet=2.0.5765-1

I didn’t check the versions. assumed they are valid

1 Like

Thanks, @emrah …Can you tell me why I need different domain name for jitsi host and turn host?

sudo apt install jitsi-videobridge2=2.1-478-gc6da57bd-1 jicofo=1.0-740-1 jitsi-meet-web=1.0.4900-1 jitsi-meet-web-config=1.0.4900-1 jitsi-meet-prosody=1.0.4900-1 jitsi-meet-turnserver=1.0.4900-1 jitsi-meet=2.0.5765-1

Is the serial ok for the components?

1 Like