WebRTC XCFramework Missing - SDK 6.2.2

I’m trying to build the latest SDK for mobile (6.2.2). I have npm 8.19.2, node 18.11.0, cocoapods 1.10.2. After running ‘npm install’ and ‘pod install’ the ‘webrtc’ xcframework should be in the directory: node_modules > react-native-webrtc > apple, however, the apple folder is empty. Does anyone have any ideas?

Perhaps try node 16

Thanks for the suggestion, however, I still have the same result.

It’s no longer distributed via npm, it gets installed with CocoaPods.

Thanks for the reply @saghul. What then is the process for building the framework ourselves? These are the steps I’ve been using since we moved to xcframeworks on iOS:
npm install
cd ios
pod install
then I run the script to build the jitsi xcframework and copy/move the webRTC xcframework to my local directory in our project.

You can use patch-package to change the framework here: react-native-webrtc/react-native-webrtc.podspec at 3f592d183b24c8dfd73eb5e9c08b0a3ca4e02a59 · react-native-webrtc/react-native-webrtc · GitHub and point it to the framework of your choosing.