Web UI post install

I tried installing Jitsi on Ubuntu 18.04,

followed this tutorial https://www.howtoforge.com/tutorial/how-to-create-your-own-video-conference-using-jitsi-meet-on-ubuntu-1804/

Installation was fine.
One thing which I didn’t followed was certificate installation, since I had my wild card certificate, I selected my own certificate with key path and crt path. Moroever I also added a DNS entry in my internal DNS record.

Note: My server is visible only internally not in public network.

Once I installed, when I open the URL with domain name in my internal network all I can see is only nginx welcome page.

I tried one more option here as well, I executed this script to test again with letsencrypt certificate, /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh and I resulted to this error with challenge failed,

Waiting for verification…
Challenge failed for domain vc.xxxx.com

Cleaning up challenges
Some challenges have failed.


  • The following errors were reported by the server:

    Type: dns
    Detail: DNS problem: NXDOMAIN looking up A for

  • check
    that a DNS record exists for this domain

Will this work only with proper DNS ‘A’ record? Also can’t I have installed with my own certificate?

Any comments would be much appreciated. Thanks in advance.

I suggest you reinstall from scratch and point the installation at your own certificates.

After doing that, paste your resulting nginx config here. I think the problem might be that nginx ignores the systen resolver so if your DNS is only reolvable internally you may need to use the “resolver” directive on nginx.

Sure, let me do from the scratch.


Installed from the scratch and it works. Now am using lets encrypt certificate, I have to use my wild card now, Hope if i change the file nginx conf and restarting the service will be enough.