We didn't find locahost jibri resource in Jitsi meet prosody

Hi, I’m Billy,

I installed and configured the Jitsi meet(including jibri) at my Linux machine(Ubuntu 20.04 & 18.04).

My host and install environment looks like this

  1. Jitsi meet and others (Ubuntu 20.04) ← installed the jitsi all(jicofo, jibri, and others)
  2. Jibri (Ubuntu 18.04) ← jutst only installed jibri

At first, i installed the jitsi at one system in Ubuntu 20.04, but jicofo didn’t find the jibri resource.
curl -s http://127.0.0.1:8888/stats | jq ‘.jibri_detector’
{
“count”: 0,
“available”: 0
}

So, i found the topic at googling that the jibri resource show at the difference host.
then i installed the other jibri at my other Ubuntu host(at number 2 18.04).
I saw the one jibri resource at jicofo with difference host’s jibri.

curl -s http://127.0.0.1:8888/stats | jq ‘.jibri_detector’
{
“count”: 1,
“available”: 1
}

I don’t know why didn’t see the same host’s jibri resource ?

Would you comment and check up my error issue ?

Best Regards,
Billy Baek

Welcome to the community.

Did you test the local Jibri to see if it records? Did you check to see if the service is running?

Hi,

Yes, local Jibri’s status is active, but i didn’t see available jibri resource.

[ systemctl log]
root@meet:/var/log/jitsi/jibri# curl -s http://127.0.0.1:8888/stats | jq ‘.jibri_detector’
{
“count”: 0,
“available”: 0
}
root@meet:/var/log/jitsi/jibri# systemctl status jibri
● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; enabled; vendor preset: enabled)
Active: active (running) since Tue 2022-06-07 17:57:28 KST; 3min 54s ago
Main PID: 851993 (java)
Tasks: 53 (limit: 19020)
Memory: 188.7M
CGroup: /system.slice/jibri.service
└─851993 /usr/lib/jvm/java-8-openjdk-amd64/bin/java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.properties -Dconfig.file=/etc/jitsi/jibri/jibri.conf -jar />

Jun 07 17:57:28 meet systemd[1]: Started Jibri Process.
Jun 07 17:57:29 meet launch.sh[851993]: SLF4J: Failed to load class “org.slf4j.impl.StaticLoggerBinder”.
Jun 07 17:57:29 meet launch.sh[851993]: SLF4J: Defaulting to no-operation (NOP) logger implementation
Jun 07 17:57:29 meet launch.sh[851993]: SLF4J: See SLF4J Error Codes for further details.

[ local jibri log ]
2022-06-07 17:57:28.638 INFO: [1] MainKt.handleCommandLineArgs#186: Jibri run with args
2022-06-07 17:57:28.751 INFO: [1] MainKt.handleCommandLineArgs#204: No legacy config file set
2022-06-07 17:57:29.201 INFO: [1] MainKt.main#55: Jibri starting up with id
2022-06-07 17:57:29.764 INFO: [1] JwtInfo$Companion.fromConfig#154: got jwtConfig: {}

2022-06-07 17:57:29.765 INFO: [1] JwtInfo$Companion.fromConfig#164: Unable to create JwtInfo: com.typesafe.config.ConfigException$Missing: /etc/jitsi/jibri/jibri.conf: 94: No configu
ration setting found for key ‘signing-key-path’
2022-06-07 17:57:29.987 INFO: [1] MainKt.main#125: Using port 3333 for internal HTTP API
2022-06-07 17:57:30.001 FINE: [18] WebhookClient$updateStatus$1.invokeSuspend#107: Updating 0 subscribers of status
2022-06-07 17:57:30.412 INFO: [1] XmppApi.updatePresence#203: Jibri reports its status is now JibriStatus(busyStatus=IDLE, health=OverallHealth(healthStatus=HEALTHY, details={})), pu
blishing presence to connections
2022-06-07 17:57:30.424 INFO: [1] XmppApi.start#156: Connecting to xmpp environment on mm.miraeson.com with config XmppEnvironmentConfig(name=mm.miraeson.com, xmppServerHosts=[mm.mir
aeson.com], xmppDomain=mm.miraeson.com, baseUrl=null, controlLogin=XmppCredentials(domain=mm.miraeson.com, port=5222, username=jibri, password=*****), controlMuc=XmppMuc(domain=inter
nal.auth.mm.miraeson.com, roomName=mrsinter, nickname=mrs123), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.mm.miraeson.com, port=null, username=recorder, password=*
****), stripFromRoomDomain=conference., usageTimeoutMins=0, trustAllXmppCerts=true, securityMode=null)
2022-06-07 17:57:30.425 INFO: [1] XmppApi.start#168: The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2022-06-07 17:57:30.461 INFO: [29] [hostname=mm.miraeson.com id=mm.miraeson.com] MucClient.initializeConnectAndJoin#278: Initializing a new MucClient for [ org.jitsi.xmpp.mucclient.M
ucClientConfiguration id=mm.miraeson.com domain=mm.miraeson.com hostname=mm.miraeson.com port=5222 username=jibri mucs=[mrsinter@internal.auth.mm.miraeson.com] mucNickname=mrs123 dis
ableCertificateVerification=true]
2022-06-07 17:57:30.462 INFO: [1] MainKt.main#152: Using port 2222 for HTTP API
2022-06-07 17:57:30.485 WARNING: [29] MucClient.createXMPPTCPConnectionConfiguration#116: Disabling certificate verification!
2022-06-07 17:57:30.524 INFO: [29] [hostname=mm.miraeson.com id=mm.miraeson.com] MucClient.initializeConnectAndJoin#340: Dispatching a thread to connect and login.
2022-06-07 17:57:30.733 FINE: [29] JibriStatsDClient.incrementCounter#38: Incrementing statsd counter: xmpp-connected:xmpp_server_host:mm.miraeson.com
2022-06-07 17:57:30.734 INFO: [29] [hostname=mm.miraeson.com id=mm.miraeson.com] MucClient$2.connected#311: Connected.
2022-06-07 17:57:30.734 INFO: [29] [hostname=mm.miraeson.com id=mm.miraeson.com] MucClient.lambda$getConnectAndLoginCallable$7#636: Logging in.
2022-06-07 17:57:30.752 INFO: [29] [hostname=mm.miraeson.com id=mm.miraeson.com] MucClient$2.authenticated#317: Authenticated, b=false
2022-06-07 17:57:30.803 INFO: [29] [hostname=mm.miraeson.com id=mm.miraeson.com] MucClient$MucWrapper.join#760: Joined MUC: mrsinter@internal.auth.mm.miraeson.com
2022-06-07 17:58:29.982 FINE: [18] WebhookClient$updateStatus$1.invokeSuspend#107: Updating 0 subscribers of status

According to the log, everything seems OK.

You may compare your installation steps with jitsi-jibri installer

Hi,
Thank you for rapid and detailed reply. :slight_smile:

As your installler link, the installer-supported platform is Ubuntu 20.04.
is it not guaranteed in the Ubuntu 18.04 ?

And Does Jibri exist different version 18.04 and 20.04 ?

Best Regards,
Billy Baek

It doesn’t work on 18.04.

There is only one stable version of Jibri. 18.04 and 20.04 uses the same package but the dependent packages and the environment are different.

Hi emrah,

Thank you for your sincerely supports.

I have more question about the jibri instance.
Is it possible multiple jibri’s instance in one host ?

If host resources such as cpu and memory are not a problem, I would like to use multiple jibri’s instances on one host.
Would you know me about this ?

Best Regards,
Billy

Not unless you’re in a dockerized environment and running docker pods for the instances of Jibri.

Hi,

Thank you for you answer :slight_smile:

I has a more question about the recording layout.
Conference moderator record a meeting, but the resolution of file is same with ffmpeg option 1920x1080, when i play a recorded file, the video is left side with half of full, the right side is black.

Question-1) Why the video not record with full size ?

Question-2) We has 4-way conference, so i think, the recorded file show 4-way tile-view, but i see the video with active talker and sharing document user. Is it possible to record the 4-way meeting screen, tile-view, as seen by the meeting organizer?

Best Regards,
Billy

Check your xorg-dummy file to make sure you’ve specified 1920x1080 as the resolution also.

Yes, the meeting organizer would needc to enable “Everyone follows me” (in ‘Settings’), then Jibri will record whatever it sees on the organizer’s screen.

Hi,

I check as your comment at “xorg-video-dummy.conf”.
I found 1920x1080 resolution value, as below.


Section “Screen”
Identifier “dummy_screen”
Device “dummy_videocard”
Monitor “dummy_monitor”
DefaultDepth 24
SubSection “Display”
Viewport 0 0
Depth 24
#Modes “32768x32768” “32768x16384” “16384x8192” “8192x4096” “5120x3200” “3840x2880” “3840x2560” “3840x2048” “2048x2048” “2560x1600” “1920x1440” “1920x1200” “1920x1080” “1
600x1200” “1680x1050” “1600x900” “1400x1050” “1440x900” “1280x1024” “1366x768” “1280x800” “1024x768” “1024x600” “800x600” “320x200”
Modes “5120x3200” “3840x2880” “3840x2560” “3840x2048” “2048x2048” “2560x1600” “1920x1440” “1920x1200” “1920x1080” “1600x1200” “1680x1050” “1600x900” “1400x1050” "1440x900
" “1280x1024” “1366x768” “1280x800” “1024x768” “1024x600” “800x600” “320x200”
#Virtual 1280 720
Virtual 1920 1080
EndSubSection
EndSection

And, As your comment, “Everyone follows me” options, i didn’t find in Settings. ??

I want to recording file with meeting organizer’s screen view.

Best Regards,
Billy

Maybe try restarting xorg:

sudo systemctl restart jibri-xorg.service

Screen Shot 2022-06-09 at 2.36.47 AM

this is useful information

Hi,

Thank your for your kindly support.

I found the “Everyone follow me” menu as you comment, the Moderator menu was hidden as default when host installation.

After that option set, the recorded layout was different in my moderator browser.
In 3-way conference, My moderator screen was vertical, but the recorded file is 2-participant in above, and 1-moderator in under.

As i mentioned before, the recorded file resolution is 1920x1080, but when playing, the video just show left half size, as like this.

Hi,

I add the below chrome option at jibri.conf, after i saw the same size with local moderator.
“–window-size=1920,1080”,

We will the jibri install at other system 18.04, then, we will configure two jibri resource.

Best Regards,
Billy

Hi,

we will try to setup for scalable jibri using docker type, as your comment.

Is this jibri docker setup URL ?

Best Regards,
Billy