Warn Component not connected, bouncing error

Hello, I am getting a warning in jicofo.log What is it for and can it be ignored?

Feb 17 10:59:24 jitsi-videobridge.my-domain.com:component warn Component not connected, bouncing error for:

Looks like your JVB cannot connet to your XMPP server.

I read that it may be a port issue?
This does not relate to being unable to adduser, I reckon?

I have

Component "callcontrol.my-domain"
	component_secret = "ugsf8gI"

in /etc/prosody/prosody.cfg.lua

It could be a port issue, yes. Do you have a firewall inplace?

I do, but shut it off and just rebooted. This message keeps being logged.
I see there are now many Exceptions logged in jicofo.log

Can you upload them in a text file?

java11 by the way on Ubuntu18 – jitsi-meet from apt

Can you try using Java 8? I’m not 100% sure (jicofo is not my forte) but I have a vague memory of a Java version causing problems.

I will look into that. I saw some of this being discussed on github I think. At the same time, a major problem is that this is filling up the logs (anything that can be done about that?)

maybe this: https://github.com/jitsi/ice4j/pull/180


I also saw this “Unmarshaller” being in util or utils I think either one of which is deprecated because its code is moved to the other one, but this code hasn’t been moved yet.

According to SO, it can be fixed by adding a Maven dependency. Is this still possible at runtime too? Or does it require to build from source?

Proper long-term solution: (JDK 9 and beyond)

The Java EE API modules listed above are all marked @Deprecated(forRemoval=true) because they are scheduled for removal in Java 11. So the --add-module approach will no longer work in Java 11 out-of-the-box.

What you will need to do in Java 11 and forward is include your own copy of the Java EE APIs on the classpath or module path. For example, you can add the JAX-B APIs as a Maven dependency like this:

<!-- API, java.xml.bind module -->

<!-- Runtime, com.sun.xml.bind module -->

I just added jakarta.xml.bind-api.jar from https://github.com/eclipse-ee4j/jaxb-ri/releases/tag/2.3.2-RI to /usr/share/jicofo/lib and https://search.maven.org/artifact/javax.activation/activation/1.1.1/jar Not sure it is a proper fix (for the exception) but the Exceptions no longer appear in the log…

Only this is still there:
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.ice4j.socket.jdk8.DelegatingServerSocketChannel (file:/usr/share/jicofo/lib/ice4j-3.0-1-ge854e4e.jar) to method sun.n$
WARNING: Please consider reporting this to the maintainers of org.ice4j.socket.jdk8.DelegatingServerSocketChannel
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

Unfortunately I still get the bounced error in the prosody log, with the Java Exceptions gone (see below). However, I have now also enabled authentication = “internal_plain”

What happens now is that the mobile client hangs on “Obtaining session-id…” after entering a username / password. The web client has the same problem. It gives:

Oops! Something went wrong we couldn’t connect to the conference: connection.GET_SESSION_ID_ERROR

The firewall is off.

Actually, I try my-domain/guest as the conference URL on the mobile client. It then asks me whether I am the host but it then immediately becomes small (not minimized) with a spinner and I get a popup: “Placing this call will end your Jitsi Meet call” -> if I click OK, The I get a “Call aborted” message. If I click Cancel, I can try to log in again, but it hangs on “Obtaining session-id…”

With the following message being repeated in jicofo.log:

Jicofo 2020-02-20 12:22:21.511 INFO: [76] org.jitsi.jicofo.xmpp.FocusComponent.handleConferenceIq().401 Focus request for room: guest@my-domain

and the bouncing error in the prosody log.

I could previously set up a video conference between an iPad and an Android tablet. So I guess this is related to configuring authentication although the bouncing error appeared before too, even when I could set up a video conference.


|Feb 20 12:27:04 jcp558a6bef4420|info|component disconnected: jitsi-videobridge.my-domain (false)|
|Feb 20 12:27:05 mod_posix|warn|Received SIGTERM|
|Feb 20 12:27:05 general|info|Shutting down: Received SIGTERM|
|Feb 20 12:27:05 c2s558a6c2f0d00|info|Client disconnected: connection closed|
|Feb 20 12:27:05 jcp558a6c29a5c0|info|component disconnected: focus.my-domain (false)|
|Feb 20 12:27:05 general|info|Shutting down...|
|Feb 20 12:27:05 general|info|Shutdown status: Cleaning up|
|Feb 20 12:27:05 general|info|Shutdown complete|
|Feb 20 12:27:39 general|info|Hello and welcome to Prosody version 0.10.0|
|Feb 20 12:27:39 general|info|Prosody is using the select backend for connection handling|
|Feb 20 12:27:39 portmanager|info|Activated service 'http' on [localhost]:5280|
|Feb 20 12:27:39 portmanager|info|Activated service 'https' on [localhost]:5281|
|Feb 20 12:27:39 portmanager|info|Activated service 's2s' on [::]:5269, [*]:5269|
|Feb 20 12:27:39 portmanager|info|Activated service 'c2s' on [::]:5222, [*]:5222|
|Feb 20 12:27:39 portmanager|info|Activated service 'legacy_ssl' on no ports|
|Feb 20 12:27:40 mod_posix|info|Prosody is about to detach from the console, disabling further console output|
|Feb 20 12:27:40 mod_posix|info|Successfully daemonized to PID 1292|
|Feb 20 12:27:40 portmanager|info|Activated service 'component' on []:5347, [::1]:5347|
|Feb 20 12:27:45 mod_bosh|info|Client tried to use sid 'bd67354e-142a-430a-94b1-f75a72b43ca0' which we don't know about|
|Feb 20 12:27:46 c2s5649b86d3bf0|info|Client connected|
|Feb 20 12:27:47 mod_bosh|info|Client tried to use sid 'bd67354e-142a-430a-94b1-f75a72b43ca0' which we don't know about|
|Feb 20 12:27:50 jcp5649b85c9420|info|Incoming Jabber component connection|
|Feb 20 12:27:50 jitsi-videobridge.my-domain:component|info|External component successfully authenticated|
|Feb 20 12:27:51 c2s5649b86d3bf0|info|Stream encrypted (TLSv1.3 with TLS_AES_256_GCM_SHA384)|
|Feb 20 12:27:51 c2s5649b86d3bf0|info|Authenticated as focus@auth.my-domain|
|Feb 20 12:27:51 callcontrol.my-domain:component|warn|Component not connected, bouncing error for: <iq id='u1DlJ-26' type='get' to='callcontrol.my-domain' from='focus@auth.my-domain/focus24931667885'>|
|Feb 20 12:27:52 focus.my-domain:component|warn|Component not connected, bouncing error for: <iq id='u1DlJ-37' type='get' to='focus.my-domain' from='focus@auth.my-domain/focus24931667885'>|
|Feb 20 12:27:54 jcp5649b85452d0|info|Incoming Jabber component connection|
|Feb 20 12:27:54 focus.my-domain:component|info|External component successfully authenticated|
|Feb 20 12:28:10 mod_bosh|info|New BOSH session, assigned it sid '9bc5fe00-23a1-427e-992b-10b5d54134fd'|
|Feb 20 12:28:10 bosh9bc5fe00-23a1-427e-992b-10b5d54134fd|info|Authenticated as 561a42a5-6f10-4785-93d2-73fff710630b@guest.my-domain|
|Feb 20 12:28:22 callcontrol.my-domain:component|warn|Component not connected, bouncing error for: <iq id='u1DlJ-56' type='get' to='callcontrol.my-domain' from='focus@auth.my-domain/focus24931667885'>|
|Feb 20 12:28:37 mod_bosh|info|New BOSH session, assigned it sid '5699151d-da4b-46b7-98da-cd276c68a2fe'|
|Feb 20 12:28:37 bosh5699151d-da4b-46b7-98da-cd276c68a2fe|info|Authenticated as quack@my-domain|
|Feb 20 12:28:38 bosh5699151d-da4b-46b7-98da-cd276c68a2fe|info|BOSH client disconnected|
|Feb 20 12:28:52 callcontrol.my-domain:component|warn|Component not connected, bouncing error for: <iq id='u1DlJ-97' type='get' to='callcontrol.my-domain' from='focus@auth.my-domain/focus24931667885'>|
|Feb 20 12:29:22 callcontrol.my-domain:component|warn|Component not connected, bouncing error for: <iq id='u1DlJ-135' type='get' to='callcontrol.my-domain' from='focus@auth.my-domain/focus24931667885'>|

What’s in your jicofo sip-communicator.properties file?

only this:


IIRC your VirtualHost was my-domain, not jitsi-meet.my-domain. You need to make them match as per the docs.