VP9 for lib-jitsi-meet (p2p)

Hi Jitsi stars,
Greetings!!!
I am using lib-jitsi-meet and trying to set preferedcodec VP9 for p2p but it’s not working still showing vp8 when p2p connection but when moves to multiparty it shows vp9 but not for 2 person call.
Browser is chrome,
Any help is really appreciated

Thanks in advance :slight_smile:

You have to set it in the P2P section of your config also.

Hi @Freddie
Thanks for quick response,
I have already set on my config for p2p but still p2p is having vp8. when I check connectionQuality localstats > codec
It shows vp8 for p2p

Can you paste the block in your config where you set the flag?

Yes @Freddie sure,
I have put inside p2p and as well outside just to be sure below is block of code
p2p: {
enabled: true,
disableH264: true,
preferredCodec: ‘VP9’,
p2pPreferredCodec:‘VP9’
},
p2pPreferredCodec:‘VP9’,
preferredCodec: ‘VP9’,

These multiple flags could perhaps be cancelling out the effect. Just set it like this:

p2p: {
        enabled: true,
        preferredCodec: 'VP9',
    },
2 Likes

@Freddie THANKS MAN!!! yeah it was cancelling out the effect, you saved the day :slight_smile:
Thanks a lot