Virtual background goes way when sharing Screen

Steps to reproduce:

  • Enable camera and set a virtual background
  • Once in the meeting, share your screen. This by turns your camera off.
  • Manually click on camera icon.

Current result:

  • Camera is turned back on and shown as a small rectangle but with no virtual background

Expected result:

  • Virtual background should remain whenever camera is enabled