Virtual backgroud does not work when screen sharing is on

First of all, thank you for keeping this project up and available for the community.

I am not sure if it is a bug, or a feature :wink:

“Tested” under latest stable releases + 20.04 + Nginx + Any browser FF/Chrome…

  1. You choose any virtual background in a meeting (or in the pre-join page)
  2. When you share your screen, by default your camera is switched off.
  3. If you switch on your camera while sharing, your image lacks virtual background
  4. When screen sharing is off, your virtual background works nicely again

Did I miss something?

Thank you!

Currently, the virtual background is not applied when presenter mode is on.

@Ashiq_Hassan There is any option to enable it (config.js/any config file)? Or it is a programming issue that should be addressed in the Jitsi To-do/wishlist?

It is a funny (well, weird) effect when you realise in a meeting :wink:

Thank you!

I think there is a feature work in progress regarding this feature and sending separate streams for screen-share and webcam video.

Maybe this one

@Ashiq_Hassan OK, thank you for your time and explanation.

We will wait then. I made a comment in the Feat for multiple streams for the sake of completeness

Let’s close for now this thread.

Follow and contribute, if possible in

1 Like

@Jose_Luis_Andrade Thanks for sharing