Videostream stopps and goes to Connection Status inactive

We have disableSimulcast: true in config.js file. Would this cause the “Inactive” issue?

We have the same issue after update to jitsi-videobridge2=2.1-376-g9f12bfe2-1 and lib-jitsi-meet#f370cccdfba6f9190ecb4afc3d78552d9f3ad57c. channelLastN is set to -1. The connection status can be set to “inactive” for a few seconds for random participants, and then it becomes “good” again. For these users I see the logs “Detector track RTC muted”.

2 Likes

It seems this is to do with congestion control on the Jitsi video bridge.

Is there any update on this?

Please. Is there any way to stop this happening. We’ve put in a TON of work on this project to record multiple guests and at the moment there’s a huge risk it’s all been a total waste of time if guests go inactive during a live stream or recording!

Does this happen with the latest stable release 2.0.5390? This thread is rather old and you do not provide any information regarding your setup/configuration.

If you are absolutely certain that sender and receiver bandwidth is sufficient and receiver processing power is sufficient and you think the issue lies in bandwidth estimation or allocation, you could try to disable bandwidth estimation. That is, disable TCC and REMB in config.js and perhaps even set trust-bwe=false in your videobridge config. This may, of course, come with other uninteded side-effects…

Sorry, for some reason I didn’t get a notification to this reply.

I’m on a developer version from github. The same version I cloned some weeks ago. I’ve just pulled the latest today though. Also trying your suggestions. Too soon to say if the problem has gone.

All my tests have been over the local network but both that and my internet are 1Gb. With a maximum of 4 clients and the server running on a dedicated mini pc running Ubuntu (not the biggest spec but a Intel Celeron J4125 Quad Core and 8GB of RAM so should be fine for 4 HD streams surely?!).

I am having the exact same problem for a couple of weeks now. I just use jitsi meet on various platforms and this happens almost on every call now. However, I have noticed that this does not happen on all networks I connect to, although the networks that have the problem are quite fast bandwidthwise. This doesn’t happen on any other conferencing platform, it is jitsi-meet specific for some reason. This is so frustrating. Is there any way to see why the connection switches to inactive?

We are using Jaas service and facing same issue. It happens when third user connects to the room (and jitsi is switching to bridge). We loose connections to all other participants for few seconds (they have inactive state), than it is recovered. Anyone can help with it, @damencho?

Anyone could help please @damencho @saghul ? It took around 30s to recover connected users from inactive state after 3rd user connected to room (we are using Jaas).

In my case, looks like restarting all routers on the LAN does the trick, but the issue comes back a few days later. Granted, my network is a bit complicated, but there doesn’t seem to be any other routing issues whatsoever!

Please report your JaaS issues to JaaS support.

There is lots of noise to signal ratio on this old topic. I’d suggest you open a new one.

Yesterday I have had two different Jitsi-Sessions (Standard-Link: https://meet.jit.si/ , Browser: Edge, Windows 10) each of 1 hour duration , both with more than 4 participants.
I was teaching dancing the others and it was a problem, that I wasn’t able to see them. I only was using the tile-mode. Audio was working perfectly.
During both sessions I have had the inactive sessions of the other participants and their thumbnails were black. Some screens of the participants flipped on for a short time and went black again, some were always off. My Bandwith: 50 Mbit down, 11 Mbit up.
All other members of both meetings haven’t had any problem. Only my sessions have had these issues.
I am always using the same equipiment and have done these kind of sessions weekly already for more than 7 times since February 2021 without issues.

In parallel I logged in to these meetings with my smartphone → no issue with thumbnails everything was fine

How can I investigate the root cause?
What can cause these kind of issues with seeing the other participants of the meeting?
Is there a workaround?
Unfortunately I am not aware of changing parameters… where can I do that?

Thank you very much for you help.

We had identified an issue and will be pushing a fix today or tomorrow for meet.jit.si.
Thank you for the report.

2 Likes

Very good news. That’s really great!! Thank you very much!

When and what version is this in the live feed to download and update ? Or is it only in the development stream ?

Latest stable has all the fixes.

Thanks - just testing now

Since 11th May 2021 I have tested with 4 Jitsi-Sessions the Video-Streaming in tile mode on
https://meet.jit.si/ and the issue seems not to be resolved yet, because it occured on all 4 Sessions.
Today I made the following observations:
I was part of a Jitsi-Session with 4 participants. One member ( I call it MemberX) wasn’t able so see my video and the others in tile mode with his Laptop (Windows/Edge/Firefox).
I clicked on MemberX’ thumbnail (in my session) to check his settings:
Connection was most of the time green:good. Connected with: eu-central-1.
It showed me permanent packet losses (between 5 and 20 %) for this MemberX and a
Arrow-Down-Bitrate (30-110 Kbps) lower than the Arrow-Up-Bitrate (235-740 Kbps) for MemberX.
Then MemberX joined in parallel with a Smartphone (same WLAN-Network) and everything worked fine with his Smartphone (tile mode videos were all ok with the Smartphone), Arrow-Down-Bitrate (about 300Kbps) was higher than Arrow-Up-Bitrate (about 200Kbps)).
Because it worked with same WLAN with the smartphone I would exclude a Network Issue for MemberX.

At the end of the Jitsi-Session only two participants were in the sessions: MemberX (with Laptop) and me. With two participants MemberX was able to see my video in tile mode with his Laptop.The issue didn’t occur with two participants.

I was always able to see MemberX in tile mode.

On another Jitsi-Session on 12th May with about 18 participants, suddenly for one participant all thumbnails videos were gone (Connected with: eu-central-1). Also for this participant the Arrow-Down-bitrate (about 65 Kbps) was lower than the Arrow-Up-Bitrate (about 2000 Kbps) and about 22% packet loss was shown.
I was always able to see the video of this participant in tile mode.

What should I check in addition if the issue appears again?