VideoParser.transform#58: Unable to find encoding matching packet!

With jitsi-videobridge2 on Debian 10, and a single videoconference running with about 12 participants of which 4 sending a video stream, I get about 70k lines per minute of this:

VideoParser.transform#58: Unable to find encoding matching packet! packet
=RtpPacket: PT=100, Ssrc=438813167, SeqNum=8562, M=false, X=true, Ts=2797473832, encodings=MediaStreamTrackDesc 1334421499 has encodings:
  subjective_quality=0,primary_ssrc=28064408,secondary_ssrcs={},temporal_id=-1,spatial_id=-1

The error also appeared with a smaller video conference ongoing. Despite the error, the videoconference appears to proceed correctly.

Is there anything I can do to debug the error? Should I tinker with the encoding settings? Is it just a bug to be reported?

The error has been reported in other discussions as well, but my server doesn’t have any of the other symptoms so I think it’s a separate issue:


Not sure if this is the same:

Versions:

$ uname -a
Linux video 4.19.0-9-amd64 #1 SMP Debian 4.19.118-2 (2020-04-29) x86_64 GNU/Linux
$ dpkg -l | grep jitsi
ii  jitsi                           2.11.5624-1                     amd64        VoIP and Instant Messaging client
ii  jitsi-archive-keyring           1.0.1                           all          The public key for the Jitsi packages repository
ii  jitsi-meet                      2.0.4642-1                      all          WebRTC JavaScript video conferences
ii  jitsi-meet-prosody              1.0.4139-1                      all          Prosody configuration for Jitsi Meet
ii  jitsi-meet-turnserver           1.0.4139-1                      all          Configures coturn to be used with Jitsi Meet
ii  jitsi-meet-web                  1.0.4139-1                      all          WebRTC JavaScript video conferences
ii  jitsi-meet-web-config           1.0.4139-1                      all          Configuration for web serving of Jitsi Meet
ii  jitsi-videobridge2              2.1-203-g83195fcd-1             all          WebRTC compatible Selective Forwarding Unit (SFU)

Hi, I can still observe this issue:

Milan

I don’t know if it’s a coincidence but the errors vanished after in /etc/jitsi/videobridge/sip-communicator.properties I set

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS

and removed:

org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443

No idea how this could have been the reason.

@FedericoB Are your servers behind NAT? All my servers have public IPv4 address.

Milan via Jitsi Community Forum - developers & users, 29/05/20 18:11:

@FedericoB Are your servers behind NAT? All my servers have public IPv4 address.

This server has a public IP address, but it’s also behind some very
bizarre proprietary firewalls so the networking is a bit unpredictable.

1 Like
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS

booth addresses have you set to your public IP address?

Thank you!

Milan via Jitsi Community Forum - developers & users, 29/05/20 23:21:

booth addresses have you set to your public IP address?

I used localhost on the first (but it doesn’t necessarily matter )

Thank you, I was only curious if you used localhost too. I’ve changed TURN address for our local turn server address, but that didn’t help.

I’ve added those two lines, but not removed turn line and that doesn’t help with error. I’m afraid to remove org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES to not lose coturn TCP relay functionality.

I’ve just updated and I’m seeing again floods of the same error “VideoParser.transform#73: Unable to find encoding matching packet!” …