Videobridge host-unknown


Hi @ all, i try to configure a second videobridge.
I set the components in prosody, set the subdomain in the vb config, allow the 5347 Port on the main serverv. I dont know where can be the problem else.

But i get the following log entry:

JVB 2018-08-02 18:17:31.824 SEVERE: [32] host-unknown,, port:5347

org.xmpp.component.ComponentException: host-unknown

at org.jivesoftware.whack.ExternalComponent.connect(

at org.jivesoftware.whack.ExternalComponentManager.addComponent(

at org.jivesoftware.whack.ExternalComponentManager.addComponent(



at org.jitsi.retry.RetryStrategy$

at java.util.concurrent.Executors$


at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(

at java.util.concurrent.ScheduledThreadPoolExecutor$

at java.util.concurrent.ThreadPoolExecutor.runWorker(

at java.util.concurrent.ThreadPoolExecutor$


the Videobridge on the local machine works fine.
here is the prosody config for the components:

VirtualHost ""
        -- enabled = false -- Remove this line to enable this host
        authentication = "anonymous"
	admins = {
        -- Properties below are modified by jitsi-meet-tokens package config
        -- and authentication above is switched to "token"
        -- Assign this host a certificate for TLS, otherwise it would use the one
        -- set in the global section (if any).
        -- Note that old-style SSL on port 5223 only supports one certificate, and will always
        -- use the global one.
        ssl = {
                key = "/etc/prosody/certs/";
                certificate = "/etc/prosody/certs/";
        -- we need bosh
        modules_enabled = {
            "ping"; -- Enable mod_ping

        c2s_require_encryption = false

Component "" "muc"
    storage = "null"
    --modules_enabled = { "token_verification" }
admins = { "" }

Component ""
	component_secret = "XXXXX"

Component ""
	component_secret = "XXXXX"

VirtualHost ""
    ssl = {
        key = "/etc/prosody/certs/";
        certificate = "/etc/prosody/certs/";
    authentication = "internal_plain"

Component ""
    component_secret = "XXXXXX"

and the config from the VB:

# Jitsi Videobridge settings

# sets the XMPP domain (default: none)

# sets the hostname of the XMPP server (default: domain if set, localhost otherwise)

# sets the port of the XMPP server (default: 5275)


# sets the shared secret used to authenticate to the XMPP server


# extra options to pass to the JVB daemon

JVB_OPTS="--apis=rest,xmpp --subdomain=vb1"

# adds java system props that are passed to jvb (default are for home and logging config file)

JAVA_SYS_PROPS="$JVB_EXTRA_JVM_PARAMS -Djava.util.logging.config.file=/etc/jitsi/videobridge/"


The component definition and the JVB_HOSTNAME differs:

You have a spelling error of double ‘t’ :slight_smile:


Two "t"s in the domain.



oh my gosh! :smiley: :smiley: :smiley:
thank you guys.
That will happen when you try to find the spelling error in the same code, all the day.

it Works!