Videobridge doesn't start, no logs


#1

Hi forumers,

after some bad tests (prosody 0.10.x from backports), I made a “good” installation : first prosody (stable 0.9.12-2), then jitsi-meet.

My problem is in the subject, videobridge doesn’t start and I don’t have any log line to clue this; a strace shows that its exit code is 0 and that is all.
jicofo is up and running and prosody’s log show it is authenticated, of course, it also shows that videobridge is: ‘Component not connected, bouncing error for …’.

I added:
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS (tested either with 127.0.0.1 & 192.168.1.233)
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS
to /etc/jitsi/videbridge/sip-communicator.properties, but no success.

Of course, all local domain & under domain names are resolved by my DNS.

Following some docs/posts on the web, I modified /etc/prosody/prosody.cfg.lua as follow:
***Globals:
+cross_domain_bosh = true
+component_ports = { 5347 }
***modules_enabled:
+“compression”;
+“bosh”;
+“smacks”;
+“carbons”;
+“mam”;
+“lastactivity”;
+“offline”;
+“pubsub”;
+“adhoc”;
+“websocket”;
+“http_altconnect”;
***EOF: 2 modifications:
+c2s_require_encryption = true
+authentication = “internal_hashed”

Prosody is complaining about modules websocket & http_altconnect missing but is starting gracefully.

A purge followed by a genuine installation did not fix the problem :confused:

Sooo, at this point, the only thing I can say is: Help, Obiwan Jitsi-meet, you are my only hope !


#2

This should be 192.168.1.233, not 127.0.0.1.

What about /var/log/jitsi/jvb.log file, do you have that, what is there?


#3

THIS is ZE problem, it stay from the former test I made (w/ the right permissions) but never updated; /run/jitsi-videobridge is also not created.

I also modified /etc/jitsi/videobridge/log4j2.xml & /etc/jitsi/videobridge/logging.properties, changing the log level to: DEBUG, but it did not work.

Here is sip-communicator.properties:
1 org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.msi.defcon1/.*
2 ### 1L MODIF: NO
3 org.jitsi.videobridge.rest.jetty.host=::
4 ##########org.jitsi.videobridge.rest.jetty.host=127.0.0.1
5 org.jitsi.videobridge.rest.jetty.port=443
6 org.jitsi.videobridge.rest.jetty.ProxyServlet.hostHeader=msi.defcon1
7 org.jitsi.videobridge.rest.jetty.ProxyServlet.pathSpec=/http-bind
8 org.jitsi.videobridge.rest.jetty.ProxyServlet.proxyTo=http://localhost:5280/http-bind
9 org.jitsi.videobridge.rest.jetty.ResourceHandler.resourceBase=/usr/share/jitsi-meet
10 org.jitsi.videobridge.rest.jetty.ResourceHandler.alias./config.js=/etc/jitsi/meet/msi.defcon1-config.js
11 org.jitsi.videobridge.rest.jetty.ResourceHandler.alias./interface_config.js=/usr/share/jitsi-meet/interface_config.js
12 org.jitsi.videobridge.rest.jetty.ResourceHandler.alias./logging_config.js=/usr/share/jitsi-meet/logging_config.js
13 org.jitsi.videobridge.rest.jetty.RewriteHandler.regex=^/([a-zA-Z0-9]+)$
14 org.jitsi.videobridge.rest.jetty.RewriteHandler.replacement=/
15 org.jitsi.videobridge.rest.jetty.SSIResourceHandler.paths=/
16 org.jitsi.videobridge.rest.jetty.tls.port=443
17 org.jitsi.videobridge.TCP_HARVESTER_PORT=443
18 org.jitsi.videobridge.rest.jetty.sslContextFactory.keyStorePath=/etc/jitsi/videobridge/msi.defcon1.jks
19 org.jitsi.videobridge.rest.jetty.sslContextFactory.keyStorePassword=changeit
20 ### ADDED: 2L: IPs INT/EXT
21 org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=192.169.1.233
22 org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=93.15.31.113
23 # PLUS DÉSACTIVATION OF IPv6: https://github.com/jitsi/ice4j/blob/master/doc/configuration.md
24 ######org.ice4j.ipv6.DISABLED=true


#4

So you have a problem with read/write permissions for the jvb user to write log/run file in /var/log/jitsi and /var/run ?

Without the log file, we can keep guessing what is the problem without any progress, so I would say fix that.

ls -l /var/log
...
drwxrwx--- 4 jvb       jitsi      4096 Oct 31 06:27 jitsi
...

#5

He no:
la /var/log | grep jit
drwxrwx— 2 jvb jitsi 37 2018-10-31 06:02 jitsi

la /var/log/jitsi/
total 80
-rw-r–r-- 1 jicofo jitsi 50069 2018-10-31 15:01 jicofo.log
-rw-r–r-- 1 jvb jitsi 27306 2018-10-31 06:01 jvb.log

NB: Local time now is: 2018-10-31 16:19


#6

BTW, how do you quote code on this forum, is it w/ BBCode ?


#7

Nope just mark the text you want to quote and you will se a menu appearing saying “Quote” :slight_smile:


#8

Nice quoting fashion :wink:

Now, what do you advise about my videobridge problem ? (Oh, when I tested w/ backports prosody (0.10.2-1), I had a jicofo connection to prosody problem but apparently none w/ videobridge, and the both of them were started.)


#9

So you don’t have currently any logs from jvb? Is the folder /var/log/jitsi permission ok?


#10

Yup, all permissions are OK, the only clue I have is an (immediate) exit code of 0.


#11

I wiped it and retried w/ backport prosody, unfortunately, videobridge hasn’t start - but /var/log/jitsi/jvb.log was overwritten during it’s installation (NB: any further attempt to start VB has failed and jvb.log was left untouched.)

Once removed the noise, this is what is left from this log file:

and this is all I get.


#12

I really love java,
its bloat, meaning you need 3x CPUs and 4-10x RAM more than for almost any other language, its GC, allowing you to sit in front of the server and wait for 20 minutes it completes, its many many configuration files, always sowed in unlikely corners of the machine, and best of all, its total lack of information when throwing a critical error…

Sooo, dissecting the whole shebang, I came with a command line that I don’t even know if it’s correct (I’ve always strived to avoid java and succeded most of the time):

which proudly spat:

Now I don’t see what I can do on top of that to make it work correctly :frowning:

There may be (?) a missing dependency toward package ‘authbind’, although AFAI understand, it is supposed to leave port 443 alone for 5443 when missing.


#13

Have you deleted that folder? When installing that folder gets created and all the configurations go in there. Hum, or it is just the command you execute have some error in it.

If you do not have nginx or apache2 installed, jetty webserver that is inside jvb is used and authbind is automatically installed and configured in order jetty to bind to ports 443 and 80.

I see Connection refused (Connection refused), host:localhost, port:5347 this is the reason jvb cannot be registered as a component and is not available. Prosody is not listening on that port.

What version of prosody do you use? Are you using the version provided from the ubuntu repositories?


#14

Make a wild guess…
Of course not and as I have saved the precedent directories, I can tell that all permissions (/etc/jitsi, /etc/jitsi/videobridge and its files) are OK/

May be, I got the whole expression from /etc/init.d/jitsi-videobridge and replaced all VARs from those in config files.

Nginx is installed, I modified the generated meet file to fit my needs, when my test worked once, it was OK.

Working:

As it failed with the Debian Stretch regular version (0.9.12-2), I installed the Debian Stretch backports version (0.10.2-1~bpo9+1) and modified its conf according to former tests; nothing was missing.


#15

Not sure why it cannot connect when it is listening. Maybe try deleting the log file and doing /etc/init.d/jitsi-videobridge restart.

A few days ago I was installing Debian 9 and was testing the install procedure and there were no issues with it.

This is strange, you had nginx installed before installing jitsi-meet? The jvb configuration you posted earlier does not indicate that, jvb is configured to run jetty on port 443 and this configured cause no nginx or apache2 had been detected to be installed.


#16

Nope, it doesn’t even recreate the jvb.log file.

Yep, with a bunch of internal sites up and running, both on 80 and 443, and some unconditional redirection from 80 to 443.

I just tested: stop nginx and try to start VB, but it is the same story (exec: -Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi: No such file or directory)

In order to try to understand what’s cooking under the hood, could you make a detailed description of who makes what and how, please ?


#17

This is the script that does most of the things:

It checks whether nginx, apache is installed and configures based on that check.
So if you see output like this:

# dpkg-query -f '${Status}' -W 'nginx'
install ok installed

Then it should configure using nginx. And for some reason it didn’t work when you initially installed it, as your jvb is currently configured to start jetty on port 443 and serve meet, that’s why I propose to you to uninstall everything and start over again:

apt-get --purge remove jitsi-meet jitsi-meet-web jitsi-meet-prosody jitsi-meet-web-config jicofo jitsi-videobridge
apt-get install jitsi-meet

This should configure nginx to serve the hostname you enter during the installation. In this situation you will not need authbind, as jvb will try binding port 443 and will fallback to port 4443 (this will be used for tcp media).


#18

I made progress, I used the manual page syntax to launch VB and it worked:

But, (and it’s a big but), nothing but signaling is sent to the other machine ; on each machine, I can see myself, but the remote’s black.

NB: My setup is quite peculiar, as almost all my gear is elsewhere at this time, so I access the other machine through X2GO - firefox doesn’t like it very much (crashes the jitsi tab) but chromium is OK. This configuration works right when testing with meet.jit.si.

Command line VB regularly throws (1x/20 seconds) a SEVERE log:

This is a small step, but now I’d like to take a giant leap :wink: