Videobridge does not start


#1

Hello Itsi-Community,

I have installed Jitsi-Meeting on my Ubuntu-Server. The Home-Screen of the Page works and I can also enter a Meeting name. Next the Main-Screen starts. If the second person connects to the server and enters the room, there comes the message: “Unfortunately something went wrong. We’re trying to fix this…”
So I checked on the console what might be the reason. Obviously the videobridge doesn’t start. If I enter

“systemctl status jitsi-videobridge.service”

I get the following Message:

jitsi-videobridge.service - Jitsi Videobridge
   Loaded: loaded (/lib/systemd/system/jitsi-videobridge.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2019-02-08 13:37:27 UTC; 4min 57s ago
  Process: 1445 ExecStartPost=/bin/bash -c echo $MAINPID > /var/run/jitsi-videobridge/jitsi-videobridge.pid (code=exited, status=218/CAPABILITIES)
  Process: 1444 ExecStart=/bin/bash -c exec /usr/share/jitsi-videobridge/jvb.sh --host=$${JVB_HOST:-localhost} --domain=${JVB_HOSTNAME} --port=${J
 Main PID: 1444 (code=exited, status=218/CAPABILITIES)

Feb 08 13:37:27 <name bash[1444]: jitsi-videobridge.service: Failed at step CAPABILITIES spawning /bin/bash: Invalid argument

I don’t know how to fix this problem. Can you help me?

Thanks in advance

Lemmermen


#2

Are you running an older kernel? For example 3.2 or older? If so, you’ll need a more recent kernel.

uname -a


#3

That’s interesting, what is your OS and version?

You can try /etc/init.d/jitsi-videobridge restart, does that change anything?


#4

Continuing the discussion from Videobridge does not start:

uname -a

Linux servername 4.4.0-042stab134.8 #1 SMP Fri Dec 7 17:16:09 MSK 2018 x86_64 x86_64 x86_64 GNU/Linux

Is this kernel too old?


#5

What about the OS and version, so I can try it myself?


#6

uname -a

Linux servername 4.4.0-042stab134.8 #1 SMP Fri Dec 7 17:16:09 MSK 2018 x86_64 x86_64 x86_64 GNU/Linux

Is this kernel too old?

It’s a Ubuntu 16.04

If I enter

/etc/init.d/jitsi-videobridge restart

this is the output:

root@servername:~# /etc/init.d/jitsi-videobridge restart
[....] Restarting jitsi-videobridge (via systemctl): jitsi-videobridge.serviceJob for jitsi-videobridge.service failed because the control process exited with error code. See "systemctl status jitsi-videobridge.service" and "journalctl -xe" for details.
 failed!

If I enter systemctl status jitsi-videobridge.service the system shows the message shown in my opening post.

About the hardware:
Its a 6-Core - Ubuntu-Server with 200GB SSD and 8 GB RAM.


#7

I will create a new VM these days and will test it with 16.04 and will report my findings.


#8

That woud be great. Thank you very much.


#9

I just created a VM on DO and tested it:

# history
    1  echo 'deb https://download.jitsi.org stable/' >> /etc/apt/sources.list.d/jitsi-stable.list
    2  wget -qO -  https://download.jitsi.org/jitsi-key.gpg.key | apt-key add -
    3  apt-get update
    4  apt-get -y install jitsi-meet
    5  service jitsi-videobridge status
# service jitsi-videobridge status
● jitsi-videobridge.service - Jitsi Videobridge
   Loaded: loaded (/lib/systemd/system/jitsi-videobridge.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2019-02-09 09:42:25 UTC; 34s ago
 Main PID: 5724 (java)
   CGroup: /system.slice/jitsi-videobridge.service
           └─5724 java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp -Djava.......

It works without a problem.

What is the exact image of ubuntu 16.04 are you installing? Does it have bash for example? Do you have any custom configurations on that ubuntu, as the standard configuration/image works without any issues?

# ls -l /bin/bash
-rwxr-xr-x 1 root root 1037528 May 16  2017 /bin/bash