Video / Sound not working outside local network

Hello

I have a working jitsi server on a local network with letencrypt certificate (thanks to masteryoda :slight_smile: )
But when I try outside the local network, it is possible to be connected, the chat works but no image is display, neither sound…
I suspect a nginx configuration problem!

My conf : a VirtualMachine A (server web Ubuntu) with nginx on internet (IP public)
a VirtualMachine B (jitsi server) with apache2 (on Ubuntu) with local IP.

The install script should have configurate correctly the apache2 (as the jitsi works on local network) but of course the script has not configure the nginx :slight_smile:
So I put a jitsi.mydomain.conf file with the redirection part:

server {
listen 443 ssl;
server_name jitsi.mydomain;

ssl_certificate xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
ssl_certificate_key xxxxxxxxxxxxxxxxxxxxxxxxxxxx
include /etc/letsencrypt/options-ssl-nginx.conf;
ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem;

location / {
proxy_pass https://192.168.x.y;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
}
}

I suspect some option are missing.
do you know where I can find the standar nginx conf ?

Or do you have a idea of the problem?

Many thanks

I found the nginx example .conf on git hub and try to add some lines more without success…

Some more information to clarify my networks…

        Internet <------------- Test PC-A
           |
           |
      +-----------------+
        IP public (DNS jisti.mydomaine = IP Public)
         Pfsense
       IP local network
       (DNS resolver => jisti.mydomain = IP local server)
       All trafic on port 80 and 443 are forwarded to vm www
      +-----------------+
           | <------------- Test PC-B
           | <------------- Test PC-C
      +-----------------+
       vm www (nginx)  
       IP local www
       (the nginx conf forward jitsi.mydomain to IP local server)
      +-----------------+
           |
           |
      +-----------------+
       vm server (apache)           
       IP local server
         jitsi server
      +-----------------+

Is there a specific port to manage on Pfsense for the video?

As far as i know you also have to forward 10000/udp for the videostream

I have try to NAT this port directly to the vm server but it does not change…

Maybe one point stange, the PC-A (outside of the local network) is connected to se jisti server but has is webcam and micro not activated (despite the fact that I have allow firefox to use them)
And if I click on it it is not activated (but I can see me in the webcam
=> So the PC-A don’t succed to send video and audio to server!