Video problem with jitsi meet torture


I have started to use script with selenium grid:

./scripts/ --conferences=1 --participants=5 --senders=2 --audio-senders=4 --duration=160 --room-name-prefix=test --hub-url=http://localhost:4444
when i am running the test on selenium grid. meeting used to start in chromium browser all parameters is running fine but problem in video…video is disabled and pop up is coming that failed to access your camera our device camera is perfecly fine

[WARNING] Tests run: 406, Failures: 0, Errors: 0, Skipped: 405, Time elapsed: 303.027 s - in TestSuite
[INFO] Results:
[WARNING] Tests run: 400, Failures: 0, Errors: 0, Skipped: 399
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 05:05 min
[INFO] Finished at: 2021-09-14T14:40:42-04:00
[INFO] ------------------------------------------------------------------

The selenium instances are bot using a real device. For malleus and such a video file is used … Probably you don’t have that locally next to the nodes.

sir , so how can i fix this problem for proper output

Make sure you pass -Dremote.resource.path=/usr/share/jitsi-meet-torture and in that folder on the server where you run chrome you need to have the file: resources/FourPeople_1280x720_60.y4m
We are using this file

Sir, after performing all this steps again video is disabled and receiving a pop up notification cannot access camera., i also tested it on another devices same issue is coming everytime.Does it acess device camera for testing and playing dummy video? If it fails to find video so it can show the video icon but it is disabled why?pls help me to resolve this issue

malleus runs on a selenium grid, I don’t understand where do you see a popup.
The chrome instances use audio and video files as mic and camera and should not access devices at all.

sir pls have a look on these snapshots that i am getting after runing command . And please provide me solution to fix this

Sir,please provide me any solution.I have been stuck since long day.

I’m not sure why is that. It gives an error in the selenium about wrong params … Maybe you need to us an older version of selenium server. Try the last 3.x version.
We are not using it locally but on a remotely deployed grids.


Seems the invalid argument exception is maybe something new in chrome 111. I may take a look later this week.

Caused by: org.openqa.selenium.InvalidArgumentException:
invalid argument
  (Session info: chrome=111.0.5563.64)

What you can try is disabling one by one options here and see which one is faulty

Nope, I’m not sure why it is failing you may try with an older version of chrome and see whether that works.

Found it. This is wrong. This should be --instance-url=

The only issue is that, while running, I cannot see the fake video that I placed to the resource folder. Sir, I do not receive any errors while executing this. Tell me the version to use to correct this if you’re talking about versions.

What files do you have in /usr/share/jitsi-meet-torture/resources ?

fakeAudioStream_license.txt ,fakeAudioStream-lipsync.wav,fakeAudioStream.wav,fakeVideoStream.y4m,FourPeople_1280*720_60.y4m ,lib,PSNRVideoOperator.js

It needs to be FourPeople_1280x720_30.y4m

ThankYou so much sir. It work finally.