Video on/off issue after joining

Hi @damencho

Working on building video conferencing app using jitsi-meet with react frontend.
I have setup jitsi on google cloud by following youtube video - https://www.youtube.com/watch?v=kOSBxvL7Y4s&t=391s and it seem working fine me.

also followed this https://jitsi.github.io/handbook/docs/devops-guide/devops-guide-quickstart.

I have added below code at to react frontend to connect jitsi-service I have setup in google cloud,

options = {
    hosts: {
      domain: process.env.REACT_APP_JITSI_ENDPOINT,
      muc: "conference." + process.env.REACT_APP_JITSI_ENDPOINT, // FIXME: use XEP-0030
    },
    bosh: `https://${process.env.REACT_APP_JITSI_ENDPOINT}/http-bind`, // FIXME: use xep-0156 for that

    // The name of client node advertised in XEP-0115 'c' stanza
    clientNode: "http://jitsi.org/jitsimeet",
  };

PROBLEM:
Created meeting and join people with video & audio ON. We all can see each other and talk.
Now When I do video off it will get off for all that fine But when I ON video again, no one can see me in the call. I can’t see any error.

Please help asap.

Thanks,

@saghul, I have create ticket here. can you please help ASAP.

@Vinayak_Kakade you really shouldn’t tag people specifically in your request for help, unless they were already helping you on the issue. This is a community support forum, don’t tag people like they’re your personal support staff. Let the community attempt to help you, like everybody else. This habit of tagging specific people when requesting help creates an undue burden on a handful of people. That’s not what a community support forum is for.

That said, what do you see in your JS console when you connect?

Generally I am not getting any error while video ON/OFF but very less it give this error (see attached

)

Once I toggle video it shows like this blank