Video not working with mobile browsers

Can anyone possibly help me?

I am developing a Flutter app with Jitsi.

I can’t use the Jitsi Meet plugin because I want to put the screen in a Stack. So I am using the flutter_inappwebview plugin.

When I access my own Jitsi server with Chrome/Mac and Chrome/Android tablet everything works fine. All other combinations (Android phone, iPhone, iPad) do not work.

The sound works but video does not.

However, if I use meet.jit.si instead of my own Jitsi server it works again.

So: it must be possible otherwise it would not work with meet.jit.si and my own server also seems to be well configured because it works with Chrome/Mac and Chrome/Android Tablet.

By the way, if I use the Jitsi Meet plugin and my own server it also works fine.

I’ve been at this for three days and am desperate.

jitsi-meet 2.0.5390-3
jitsi-meet-prosody 1.0.4628-1
jitsi-meet-turnserver 1.0.4628-1
jitsi-meet-web 1.0.4628-1
jitsi-meet-web-config 1.0.4628-1
jitsi-videobridge2 2.1-416-g2f43d1b4-1
Ubuntu 18.04.6

I dont see a real issue to use jitsi_meet | Flutter Package in a Stack on flutter. It sounds its a permission issue with your camera.

Try to follow the install guide of the widget. The main area for web should be considered

Also would be good to have the log of errors you get in order to pin out your problem

The jitsi_meet plugin works fine but I can’t place it in a Stack because it is not a widget. I start a chat with JitsiMeet.joinMeeting() and then the JitsiMeet class takes over the whole screen. I can’t influence it anymore. Ans it’s not a permission issue. I can see myself :slight_smile:

Let’s clarify that is a widget. All UI components in flutter are widgets. As I understand you want to put it on an Stack to accomodate other widgets in the same screen correct?

Would be helpful you share the dart code you are trying to implement to see it

Also any log error you get

It’s not a widget. Is’s a method. A soon as the method got fired my Widget tree disappears. I don’t have an error log because it works fine.

@override
Widget build(BuildContext context) {
  return new Scaffold(
    key: _scaffoldKey,
    body: SafeArea(
      child: Container(
        child: Center(
          child: Text(
            'This is my page',
          ),
        ),
      ),
    ),
  );
}
_joinMeeting() async {

    Uuid uuid = Uuid();

    String? key = uuid.v4().toString();

    String serverUrl = 'https://' + subdomain + '.' +  VIDEO_DOMAIN;

    Map<FeatureFlagEnum, bool> flags = Map<FeatureFlagEnum, bool>();

   // set all the flags

    var options = JitsiMeetingOptions(room: key!)
      ..serverURL = serverUrl
      ..audioOnly = false
      ..audioMuted = true
      ..videoMuted = false
      ..featureFlags = flags;

    JitsiMeet.joinMeeting(options, listener: JitsiMeetingListener(
      onConferenceWillJoin: _willJoin,
      onConferenceJoined: _joined,
      onConferenceTerminated: _terminated,
      onPictureInPictureWillEnter: _pictureInPictureWillEnter,
      onPictureInPictureTerminated: _pictureInPictureTerminated));

  }

My point is that you can wrap it in a class widget where you can control the size …
But in your log in your server there are no logs in jvb.log ? Or in Jicofo.log ?

I will switch to Connectycube. It will solve my problem. Thank you very much anyway.