Video is getting disabled in filmstrip

in a meeting, there are around 10 users in that 7 users are enabled the camera.
in that 4 are muted the audio. 3 enabled both audio and video

we can see the remaining 3 participant video is appearing but the other 4 users’ video is not appearing.
I think it’s disabled due to inactivity.

but is there a way to display all user’s videos irrespective of they are muted audio or not?

is there a config to enable this feature?

Thanks in Advance.

What icons do they have when the video is not displayed is it the ninja one? If yes, this means the bridge stopped them due to insufficient bandwidth available on the receiver.

@damencho Yes, it’s a ninja icon. but when I switch to tile view all their video was appearing… it should happen for both the right tile view and filmstrip?

is there a way to fix it?

@damencho


in above screenshot 3 users having ninja icons.

but the same user’s video is visible in the below image when it’s in tile view.

Well, at first glance it seems normal. So you have one big on-screen taking all your available bandwidth and there is no availability for the thumbnails. But when you request low resolutions for all, the download link is enough and sends those.
What is the approximate download in stage view one, and what is the download in tile view?

In the first instance, there’s one HD resolution (2500kbps) and 4 180p, in the 2nd instance, everything is 180p (200kbps). You need more bandwidth for that Stage view.


You need to check your local connection not the remote.


I assume this is on meet.jit.si? What’s your local network speed (up/down)? Try:

@Freddie Yes it’s on meet.jit.si

That doesn’t seem too bad - certainly should be able to support a test case of 5 participants.

I ran the same test on an older machine with average specs. With 5 tabs and VP9 decoding, it put the machine to work, but here’s my result:

I am running on slightly better speeds though.

One note: those thumbnails in tile view are actually rendered in 360p, not 180p, like I mentioned earlier.

@Freddie it means… it all depends upon the internet bandwidth and it has nothing to do with any configuration on the server or local right?

Yes, it’s a network-related finding. The machine power as well as the codec negotiated also play a role (VP9 decoding requires more CPU). Maybe test with one Firefox user (to force VP8) and see if you observe a difference.

I tested again with 6 participants, to match your test and my findings were the same:

1 Like

@Freddie, @damencho I wanted to know about the following scenario…

When receiver bandwidth is LOW at that time we get remote connection status as INACTIVE?
but when sender bandwidth is LOW how do we determine it?. for that also do we get the status as INACTIVE?

Think about it like this: upload bandwidth affects send, download bandwidth affects receive.

When local upload bandwidth is low, the other parties in the meeting may lose the stream of that user and the user may see the message “video suspended due to insufficient bandwidth…” or something like that.

When download bandwidth is low, the user will see some of the remote videos go off and their connection indicators will show a ninja icon.

1 Like

@Freddie but in both the cases are we using status as INACTIVE…?

can you please tell me the exact message we are displaying in case of the Low upload?

I can see only the following message:
"LOW_BANDWIDTH": "Video for {{displayName}} has been turned off to save bandwidth"

if we are using the above msg then it will be common to upload and download as well?

const messageKey
= connectionStatus === JitsiParticipantConnectionStatus.INACTIVE ? ‘connection.LOW_BANDWIDTH’ : null;

we are using the above statement to show the message but similarly, the ninja icon drove by INACTIVE

if (this.props._connectionStatus === JitsiParticipantConnectionStatus.INACTIVE) {
            if (this.props._connectionIndicatorInactiveDisabled) {
                return null;
            }

            return (
                <span className = 'connection_ninja'>
                    <Icon
                        className = 'icon-ninja'
                        size = '1.5em'
                        src = { IconConnectionInactive } />
                </span>
            );
        }

There’s LOST and then, there’s INACTIVE.

The “LOW_BANDWIDTH” message is shown for upload, AFAIK. For download issues, the inactive (ninja) icon is seen on select remote videos.