Video: crop and black bars

Hello,

I hope you are doing well during these compli-coronated times.
I am not a computer specialist, but a simple user of Jitsi services.

I am faced with the following problem:
When I use my webcam (Logitech c920) on jitsi.org, the image is complete.
When I use another site based on Jitsi, the image is croped.
The problem is the same under Firefox or Chrome.

Can someone more qualified than me tell me what to do?

  • A modification of my system?
  • A modification at the videoconferencing service provider?

Thank you for your interest in my message.
Best regards

FriGli

On jitsi.org

On jitsi based service

in
/usr/share/jitsi-meet/interface_config.js
try set
MAXIMUM_ZOOMING_COEFFICIENT: 1,

on meet.jit.si this is set to 1.3
https://meet.jit.si/interface_config.js

you can look at meet.jit.si config.js and interface_config.js and compare with your settings

Hello xranby,

Thank you for your reply.
I will pass it on to the managers of the site based on jitsi.

Best regards

Hi, I have the same issue with Logitech C920s. All people with this webcam have a cropped video on the sides when in mosaic view. I tried the MAXIMUM_ZOOMING_COEFFICIENT: 1, But it just makes it worse, it now crops the video when NOT in mosaic view, which is not happening with the zooming coefficient set to 1.3.
People with laptop webcams seem fine (DELL XPS 15 i9).

The solution for me was to make sure I had the following lines uncommented (especially the aspectRatio key-value in the Video section of my /etc/jitsi/meet/jitsi.domain.tld-config.js

     constraints: {
         video: {
             aspectRatio: 16 / 9,
             height: {
                 ideal: 720,
                 max: 720,
                 min: 240
             }
         }
     },

And then restart prosody/jicofo/jitsi-videobridge2 services (probably only need to restart one of them… not sure which :))

Hope this helps!