Video bridge issue when > 2 users

Hi,

I know this issue is one of the most discussed ever one, however, went through the forum and did many things, the issue is still present!

Trying now to list the full story to what I did so far:

  1. Environment is Ubuntu 20.04.1 LTS (Focal Fossa) – architecture is arm (aarch64)
  2. Running on AWS EC2
  3. Security groups allow traffic on ports: (HTTPS, HTTP and UDP10000)
  4. UDP10000 port is accessible from outside the instance (verified by taking captures on port udp10000 and sent traffic on it from outside using nc)
  5. Installed it using the quick-installation formal guide
  6. Certificate is configured using lets-encrypt

Issues I’ve faced so far:

  1. Exception in thread “Smack-Single Threaded Executor 10 (0)” java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.videobridge.sctp.SctpManager
    -> From other discussions, it sounds like architecture mismatch, so I tried to enable websockets as a solution. Followed this link (jitsi-videobridge/web-sockets.md at master · jitsi/jitsi-videobridge · GitHub) by damencho, step by step. But still see that websocket is not being called (by checking the troubleshooting section in the same topic)

    -> I have another older instance where I don’t face this issue, so checked the version on Videobridge there, and downgraded the fresh instance with the same version – no luck

    -> Tried installation using buster installer for Jitsi – no luck

    -> Did more and more things, almost read all of topics discuss about the > 2 participants hung issue, the only thing I didn’t try is to compile videobridge on the same server!

Anyone can help? It took me 3 days so far without result.

Thanks in advance

Did you try to install exactly the same way on AMD64 to be sure if this is an arch related issue or not?

Yes, followed the steps one by one.

Could you successfully install a working Jitsi on AMD64?

Actually tried that on VBox… worked fine on AMD64 VM.

So it’s definitly an arch issue.

According to the forum, enabling websocket will avoid calling Sctp, so we can live with that in ARM arch environments.

I’ve double checked the websocket config in my setup as per (FAQ · Jitsi Meet Handbook), they are identical and look correct! However, still can’t see the websocket requests initiated from any session I open. Instead I have the following request, which is not web-socket one!

Sorry! the request is too long and couldn’t paste it here… couldn’t upload it as well

Anyone can help me here? Almost gave up :frowning: spent a full week on this problem with no luck!