Video and sound no record after Latest Nginx 1.20.0 Security Update

After Latest Nginx security update I got face an issue over jibri.Jibri workers joining the videocall but after the video call completed successfully ffmpeg video and sound not recording to jibri. I suspicious on UDP. Anyone faced this issue?

 Here is the security patch changes:
  "Security: 1-byte memory overwrite might occur during DNS server
   response processing if the "resolver" directive was used, allowing an
   attacker who is able to forge UDP packets from the DNS server to
   cause worker process crash or, potentially, arbitrary code execution
   (CVE-2021-23017)."

Welcome to the forum.

Share your jicofo.conf.

Greetings:) here is my jicofo conf file:

jicofo {
  xmpp: {
    client: {
      client-proxy: focus.meet.xxxx.com
    }
    trusted-domains: recorder.meet.xxxx.com
  }
}
~

Change that to:

trusted-domains: [recorder.meet.xxxx.com]

Then restart services.

Problem solved but thanks for help.Just curiosity how this solved problem changed that to array?

I think you have not the latest stable. This is a bug solved in the new release.

1 Like