Version of NodeJS

Hello. Which version of NodeJS is required for jitsi-meet and lib-jitsi-meet repos?
Firstly I worked only with jitsi-meet repo and NodeJS 12.16 was ok (on macOS Catalina and on Ubuntu 18.04).
But yesterday I tried to make ‘npm install’ in lib-jitsi-meet rep on MacOS and it gave a lot of errors. (ubuntu still works ok).

So, which version I should use for mac and for ubuntu? And can I use different versions?

I have the following errors on MacOS with nodejs v12 or more fresh:

fsevents@1.2.4 install /Users/fedin/.Trash/lib-jitsi-meet/node_modules/karma/node_modules/fsevents
node install

node-pre-gyp WARN Tried to download(404): https://fsevents-binaries.s3-us-west-2.amazonaws.com/v1.2.4/fse-v1.2.4-node-v83-darwin-x64.tar.gz
node-pre-gyp WARN Pre-built binaries not found for fsevents@1.2.4 and node@14.0.0 (node-v83 ABI, unknown) (falling back to source compile with node-gyp)
  SOLINK_MODULE(target) Release/.node
  CXX(target) Release/obj.target/fse/fsevents.o
In file included from ../fsevents.cc:6:
In file included from ../../nan/nan.h:221:
In file included from ../../nan/nan_converters.h:67:
../../nan/nan_converters_43_inl.h:22:1: error: no viable conversion from 'Local<v8::Context>' to
      'v8::Isolate *'
X(Boolean)
^~~~~~~~~~
../../nan/nan_converters_43_inl.h:18:23: note: expanded from macro 'X'
      val->To ## TYPE(isolate->GetCurrentContext())                            \
                      ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
/Users/fedin/Library/Caches/node-gyp/14.0.0/include/node/v8.h:2845:37: note: passing argument to
      parameter 'isolate' here
  Local<Boolean> ToBoolean(Isolate* isolate) const;

// a lot of same errors

atal error: too many errors emitted, stopping now [-ferror-limit=]
2 warnings and 20 errors generated.
make: *** [Release/obj.target/fse/fsevents.o] Error 1
gyp ERR! build error
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:194:23)
gyp ERR! stack     at ChildProcess.emit (events.js:315:20)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:276:12)
gyp ERR! System Darwin 18.7.0
gyp ERR! command "/usr/local/Cellar/node/14.0.0/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "build" "--fallback-to-build" "--module=/Users/fedin/.Trash/lib-jitsi-meet/node_modules/karma/node_modules/fsevents/lib/binding/Release/node-v83-darwin-x64/fse.node" "--module_name=fse" "--module_path=/Users/fedin/.Trash/lib-jitsi-meet/node_modules/karma/node_modules/fsevents/lib/binding/Release/node-v83-darwin-x64" "--napi_version=6" "--node_abi_napi=napi"
gyp ERR! cwd /Users/fedin/.Trash/lib-jitsi-meet/node_modules/karma/node_modules/fsevents
gyp ERR! node -v v14.0.0
gyp ERR! node-gyp -v v5.1.0
gyp ERR! not ok
node-pre-gyp ERR! build error
node-pre-gyp ERR! stack Error: Failed to execute '/usr/local/Cellar/node/14.0.0/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/Users/fedin/.Trash/lib-jitsi-meet/node_modules/karma/node_modules/fsevents/lib/binding/Release/node-v83-darwin-x64/fse.node --module_name=fse --module_path=/Users/fedin/.Trash/lib-jitsi-meet/node_modules/karma/node_modules/fsevents/lib/binding/Release/node-v83-darwin-x64 --napi_version=6 --node_abi_napi=napi' (1)
node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (/Users/fedin/.Trash/lib-jitsi-meet/node_modules/karma/node_modules/fsevents/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
node-pre-gyp ERR! stack     at ChildProcess.emit (events.js:315:20)
node-pre-gyp ERR! stack     at maybeClose (internal/child_process.js:1051:16)
node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:287:5)
node-pre-gyp ERR! System Darwin 18.7.0
node-pre-gyp ERR! command "/usr/local/Cellar/node/14.0.0/bin/node" "/Users/fedin/.Trash/lib-jitsi-meet/node_modules/karma/node_modules/fsevents/node_modules/node-pre-gyp/bin/node-pre-gyp" "install" "--fallback-to-build"
node-pre-gyp ERR! cwd /Users/fedin/.Trash/lib-jitsi-meet/node_modules/karma/node_modules/fsevents
node-pre-gyp ERR! node -v v14.0.0
node-pre-gyp ERR! node-pre-gyp -v v0.10.0
node-pre-gyp ERR! not ok
Failed to execute '/usr/local/Cellar/node/14.0.0/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/Users/fedin/.Trash/lib-jitsi-meet/node_modules/karma/node_modules/fsevents/lib/binding/Release/node-v83-darwin-x64/fse.node --module_name=fse --module_path=/Users/fedin/.Trash/lib-jitsi-meet/node_modules/karma/node_modules/fsevents/lib/binding/Release/node-v83-darwin-x64 --napi_version=6 --node_abi_napi=napi' (1)

> lib-jitsi-meet@0.0.0 postinstall /Users/fedin/.Trash/lib-jitsi-meet
> webpack -p

Hash: e59b867b10ac65ae184f
Version: webpack 4.43.0
Child
    Hash: e59b867b10ac65ae184f
    Time: 5150ms
    Built at: 04/05/2020 11:14:25
                     Asset      Size  Chunks                   Chunk Names
     lib-jitsi-meet.min.js   662 KiB       0  [emitted]        lib-jitsi-meet
    lib-jitsi-meet.min.map  2.77 MiB       0  [emitted] [dev]  lib-jitsi-meet
    Entrypoint lib-jitsi-meet = lib-jitsi-meet.min.js lib-jitsi-meet.min.map
      [2] ./JitsiConferenceEvents.js 9.35 KiB {0} [built]
      [3] ./modules/browser/index.js 98 bytes {0} [built]
      [5] ./modules/statistics/statistics.js 21.9 KiB {0} [built]
      [7] ./service/statistics/AnalyticsEvents.js 17.4 KiB {0} [built]
      [9] ./service/RTC/MediaType.js 184 bytes {0} [built]
     [11] ./modules/util/GlobalOnErrorHandler.js 2.1 KiB {0} [built]
     [12] ./modules/RTC/RTC.js 27.3 KiB {0} [built]
     [13] ./JitsiTrackErrors.js 2.54 KiB {0} [built]
     [15] ./JitsiTrackEvents.js 1.32 KiB {0} [built]
     [16] ./JitsiTrackError.js 5.6 KiB {0} [built]
     [18] ./JitsiConferenceErrors.js 2.15 KiB {0} [built]
     [20] ./modules/detection/DetectionEvents.js 2.51 KiB {0} [built]
     [22] ./modules/videosipgw/VideoSIPGWConstants.js 1.46 KiB {0} [built]
    [134] ./index.js 160 bytes {0} [built]
    [135] ./JitsiMeetJS.js 21.6 KiB {0} [built]
        + 138 hidden modules
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/karma/node_modules/fsevents):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 install: `node install`
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

audited 9163 packages in 13.902s

3 packages are looking for funding
  run `npm fund` for details

found 112 vulnerabilities (111 low, 1 high)
  run `npm audit fix` to fix them, or `npm audit` for details

As I understood the problem is lib ‘core-js’. It is too old and don’t work with nodejs v12. If update it to the last one version then the problem with npm install will be solved.