Various issues with fresh installs on Ubuntu 18.04

Hi all,

I’ve been trying to get an instance running on a new Digital Ocean droplet running Ubuntu 18.04. The server is not behind a NAT. I’ve closely followed the quick-install guide and also tried several purges, re-installs, and separate installations of nginx and jitsi-meet (without the turnserver config).

It seems that my problem persists: I can open a room and as soon as anyone else joins the room crashes. The browser was reporting issues about videobridge missing. Initially, I assumed that we needed to increase the droplet’s memory, however, the issue persisted.

The most obvious issue in the JVB log was this: SASLError using SCRAM-SHA-1: not-authorized

Using these hints I’ve tried several solutions present in the forum, but could not get jitsi-meet to even hose two participants.

I was hoping that someone could give some more definitive advice on whether this is an issue that I can fix by scouring the forum or if this might be an issue with the latest release for Debian.

Thanks!

Seemingly related threads (I might have missed a few others):

Hi there,
Not sure if this helps at all.

  • I start the services in this order: prosody, jicofo, videobridge, apache.
  • Use google chrome if you can. Firefox isn’t supported.
    Sorry if these are things you’ve already tried!

Thanks for the pointers! I’ve been through various combinations of the service startup order and kept running into the same problem. And yes, I’ve been using Chrome instead of Firefox.

not sure if it helps, but I have written this tutorial for hetzner, it might work as well for digital ocean (I haven’t tried though): A tutorial to self-host a Jitsi server with authentication

I just wanted to close this thread! Just tested it with a fresh install and the recent fixes worked for me.