UVC camera stopped working

I have been using this Logitech UVC camera for many years with jitsi. Early on it required a hack in the URL to connect to the camera. Then it started to work without the hack. Off and on it has been a bit “fraglile” but then would settle in for a while. It was working last night. Today no camera only audio. The camera light comes on but then goes off. Preview is blank. The camera and audio toggles are non-functional. The selected options are correct in jitsi settings and both camera and mic are allowed in browser settings on chromium. You have clue what’s going on? I’m suspecting a fubared upgrade . . .

Chromium Version 112.0.5615.138 (Official Build) built on Debian 11.6, running on Debian 11.1 (64-bit)

Hey there, welcome to our community!

Does the camera work in this demo? Select audio and video sources

Thanks for the response, saghul. I haven’t had to bother you folks for many years. Hope you can figure this out. Have an important meet tomorrow.

This is the output from the link you provided and it is correct:

Audio input source: Default
Audio output destination: Default
Video source: UVC Camera (046d:0825) (046d:0825)

Here’s additional info in the camera:
Logitech C270
Vendor ID 0x461
Product ID 0x825

The settings accessed from the Join Meeting screen are identical but it only says that “your microphone is working properly”. Then a few seconds latter a message pops up about the “camera not working properly”

When I join the session, both icons appear as active but the video icon will not toggle. The light on the camera comes on for maybe 10 seconds then goes off.

Sorry, this might be a better test: getUserMedia: select resolution

Do all resolutions work? Which one(s) fail?

I am a bit of a technophobe and not interested in bling so still using VGA . . . if it works don’t fix it!

Moniitor resolution is1920x1200

Result of the second test even though the camera’s green light was on when it connected was:
“getUserMedia: Requested device not found”

Jitsi has been working for many years with this camera on this monitor including 2 days ago.

I may try to dig up the hack for the URL that I got from your team on IRC maybe 8 years to solve a similar if not identical problem

I just checked Best Buy and they are still selling the C270! So I’ve ordered one to pick up tomorrow. It might just be that the old camera has died. Unlikely but worth a try.

OK! I found the hack for the end of the url that worked years ago for an obviously old monitor:

Would something like that be available for my current monitor?

This may be related with the browser. A few days ago, there was a new update for chromium and looks like you have this updated version.

You may try to downgrade it or using another browser.

Thanks for the suggestion, emrah.

Sadly, I upgraded in an attempt to fix the problem so downgrading won’t help. I just picked up the identical replacement mentioned above but can’t test ATM. Need food. Hopefully it will work in time for the jitsi meet scheduled in 3 hours . . .

As to other browsers . . . jitsi never worked very well in firefox and Palemoon . . . well . . .

New camera works. Sorry for the noise . . .

I think Chromium must have become picky with yours. Even if it doesn’t support 720p, the default resolution we ask for, we do set a minimum of 240, and yours should’ve been opened at 360.

Thanks for the info. Good to know that you are still providing those resolution options but I don’t understand why Chromium would have suddenly become picky on a version that had been working normally for several weeks. Would test more if I had another device . . .

In any case, thankfully new camera is working.

A bit of an update . . . yesterday at the jitsi meet, one of the participants from Argentina also couldn’t connect. He sent this note to me:

“Thing is that I fired up the same jitsi.appimage I have been using all this time but it would not allow camera or microphone access. I had video and sound from outside but nothing else. No idea why. Maybe the latest updates?”

A third person in US new to jitsi did not manage to connect at all. FWIW . . . our jitsi connection is via the GARR network in Italy.

The plot thickens . . .

Any chance you can test meet.jit.si ?

Of course I was testing the two one after the other. Not at the same time. Identical results. I do use meet.jit.si for some other things and it usually FIXES the problem so this is unusual. My new camera works on both now,

The only thing I can think of is the resolution fallback having gone sideways in Chrome.

My friend in Venezuela uses FF.

Do they have the same camera?

Unknown. Probably not. He does use older hardware though as most of my circle of acquaintances does. I’ve given him the link to this thread. He may join in.


Here I am.
I’ve been using jisti for a short time, never used any video conferencing before.
Interesting …

I had been invited to participate in a meet, so I purchased a USB camera (Genius QCam 6000) and set it up.

I plugged it in, my Devuan Linux installation detected it and sound/video worked.
I was on my way, or so I thought.

A couple of afternoons attempting to get jitsi to work with Firefox, Chromium, Pale Moon and LibreWolf were a no-go.

Mostly there was video (bad/grainy) but the microphone would simply not work.

As the meet was approaching and time was running short, I downloaded jitsi-meet-x86_64.AppImage, ran it and …

It worked out of the box, first time out. 8^D

Happy with the result, I continued attending weekly meetings for months till a couple of days ago something went awry.

As usual, I fired up jitsi-meet-x86_64.AppImage only to find that I had lost microphone and video and there was no way to turn them on.

Out of the blue and for no apparent reason, I no longer had permission to do so.
ie: I could see and hear the people at the meet but they could not see or hear me because there was no active camera or microphone.

I checked permisisons and they were as they should be.

So I rebooted (just in case), tried again with all the browsers, the appimage and even installed the *.deb version: the issues remained.

Later that day (no reboot) I decided to try again and …

Both the appimage and the *.deb version worked properly.

No idea what or why.

The only thing that came to mind yesterday was that as the camera/microphone is an all-in-one USB thing, there may have been something USB-ish going on.

But that does not necessarily explain the permission issue.
I expect that jistsi would have complained that it did not detect a camera or a microphone but it did detect both.

It just did not have permission to activate them.

That’s all I can say.
The problem went away suddenly and silently as it came.
Maybe it has to do with planetary alignments.