Using (latest) meet.jit.si - some questions

EDIT:

Sorry, new users can only put one embedded media item in a post.
Sorry, new users can only put 2 links in a post.

Well, thank you for letting me know, after I wasted nearly an hour uploading and collecting links - very considerate! Why didn’t anyone think of giving these warnings while the post is being rendered live during writing, where links are automatically parsed anyways?


I wanted to use https://meet.jit.si/ to chat with a friend; we tried it once, I was on Firefox on Linux laptop, and he was using a tablet (I think it was Android, and he was likely using a web browser, possibly Chrome). We experienced the following problems here:

  • I could hear him talking, but he could not hear me talking - even if my “VU meter” for the chosen audio input was showing that there is audio being captured
  • He could see my camera video, but he could not enable his camera, and so could not stream video

So, I decided to do a local test at home, between a smartphone and the laptop - both on the same local Wi-Fi network. After only a couple of minutes, I got a “Video turned off to save bandwidth” on the smartphone (which I found surprising, as all devices are on the same WLAN after all, and bandwidth should not have been an issue), and I couldn’t figure out how to turn it back on. So my first question is:

  1. Is it possible to re-enable video, once it is “Video turned off to save bandwidth” - and if so, how?

So, I decided to reproduce this problem and get some screenshots; the imgur album link for this is jitsi test - Album on Imgur (unfortunately, it seems these days it is impossible to get images on imgur in order, even if you upload them one by one - one could wish someone invented an advanced computer program that keeps the order of images); the participants here are:

  • Laptop: old ThinkPad running Ubuntu Mate 20.04.5 LTS, using Firefox 104.0 from the Ubuntu repos
  • Smartphone: LineageOS 17.1 (Android 10), using the Jitsi Meet app (latest from F-droid)

Again, both devices are on the same local Wi-Fi network; however, this time I did not get “Video turned off to save bandwidth” - even if it is the same setup that I’ve used previously, which gave me this message.

  1. If using Jitsi on an Android smartphone or tablet, is it better to use the app, or a browser? If app, are there differences between F-droid and Google Play version - and if so, which version is preferable?

Then, I started “MyLocalTestingRoom” from laptop/Firefox.

  1. Is there a concept of “ownership” of a room in Jitsi (just the plain https:// meet.jit.si without any special subscriptions)? Is the “owner” the one who first created the room? Can “ownership” of a room be transferred?

Once I joined the room from laptop/Firefox, I can notice a menu toolbar on the bottom;

https:// i.imgur .com/DSGmOcKs.png https:// imgur .com/DSGmOcK

On that menu, there is a “Raise your hand” icon.

  1. Does the “Raise your hand” icon have anything to do with muting or unmuting of audio (or any other functionality) - or is it purely symbolic?

Then, I used the “Jitsi Meet” app on the smartphone, to connect to the same room, it worked fine. Here, I can notice, that if I click the small arrow over the microphone icon, I will get “Audio Settings” which basically just shows a list of audio input devices, with “VU meters”

imgur .com/vrj4C2k

  1. If from here, I can see that I have chosen a microphone/audio input device that has a properly functioning “VU meter” - does that mean that the other side should hear me (provided I’m not muted somehow)?

Furthermore, on laptop/Firefox, there are “Performance settings”, which shows a slider, which by default is on “Highest quality”:

https:// i.imgur .com/XgDvvJis.png https:// imgur .com/XgDvvJi

What surprised me a bit, was that if I set the slider to the lowest setting “Best performance”, video is completely disabled:

https:// i.imgur .com/ZnTg41Us.png https:// imgur .com/ZnTg41U

… however, the setting right next to it then enables the video again.

  1. For whom is the “Performance settings” slider available? Is it available only for the owner of the room - and if so, does it then control settings for all participants in the room? Or maybe, it is available only for browsers (in which case it would control only individual settings for the respective participant on that browser)?

Looking at the smartphone “Jitsi Meet” Android app, it already has a “Join In Low Bandwidth Mode” button:

https:// i.imgur .com/Riviw3ds.png https:// imgur .com/Riviw3d

… but even if you just click “Join Meeting”, later you can click on the “three dots” icon in the menu toolbar on the bottom:

https:// i.imgur .com/HYhMsf3s.png https:// imgur .com/HYhMsf3

… and you’ll get a bunch of options, among them “Enable low bandwidth mode”:

https:// i.imgur .com/fkmQgVJs.png https:// imgur .com/fkmQgVJ

I’ve noticed, this “low bandwidth mode” on the Android app just simply kills the video completely:

https:// i.imgur .com/lp5Sct6s.png https:// imgur .com/lp5Sct6

  1. Is it possible, on the Android app, to choose a “low bandwidth” mode, but with video - something like the second setting on the “Performance settings” slider for the Jitsi on laptop/Firefox?

(Actually, I would have hoped, all Jitsi clients would have a setting to explicitly downscale/transcode video to say 24p height, 25 fps, which I believe would have resulted with least bandwidth usage, even if the video quality would be very low - all these “adaptive” controls, more often that not, simply result with no video at all).

Finally, just wanted to note, that when I exited “low bandwidth mode” on the Android app, it remained not streaming its own video:

https:// i.imgur .com/a76I5PVs.png https:// imgur .com/a76I5PV

… which I thought of submitting as a bug - but then, after about a couple of minutes (maybe up to five), the app sort of “recovered” and started streaming its own video again; so I guess it is just a slow reaction to “adaptive” controls/changes.

Many thanks in advance for any answers!

That’s something Discourse does, sorry about that.

It’s not possible. Even though you might have had the bandwidth, there are other factors that could’ve affected it, like packet loss. Were you too far from the WiFi AP maybe?

The app should give you a better user experience. The F-Droid build gets released a few days after the Play Store ones, and are of the “libre” flavour, aka they contain no analytics nor Google libraries. The best here would be to test the Play Store Beta version, which is the upcoming release.

No, there isn’t such a concept. Rooms get created when the first participant joins and destroyed when the last one leaves. All users are moderators. These are meet.jit.si features, if you deploy Jitsi Meet on your own server you can choose different auth mechanism and so on.

It’s symbolic.

This was on the desktop, right?

Correct.

This is the designed behavior.

It’s for each participant, it’s local policy.

That’s actually the default behavior, the default quality is lower than 720p.

1 Like

Many thanks, @saghul - exactly the answers I needed! :slight_smile:

Yeah, sorry I started the post of with a complaint - but it really ended up irking me …

Not really, both devices were in more or less the same room as the WiFi AP, max 5 m distance …

This about other factors made me think of something I read, I cannot find the exact quote now, but this is close enough - https:// jitsi. org/e2ee-in-jitsi/:

Jitsi meetings in general operate in 2 ways: peer-to-peer (P2P) or via the Jitsi Videobridge (JVB). This is transparent to the user. P2P mode is only used for 1-to-1 meetings. …

This outer layer of DTLS-SRTP encryption is removed while packets are traversing Jitsi Videobridge; however they are never stored to any persistent storage and only live in memory while being routed to other participants in the meeting.

I was thinking, maybe the smartphone video got routed to whatever Videobridge server the meet.jitsi .org website is using, and that part of the connection was losing packets …

( Then again, the test in OP is purely 1-to-1, so I guess in that case P2P should have been chosen as default transport, in which case no videobridge to central server, meaning connection between the device should have been within local network … but I cannot tell really )

Yes, I’ve observed the VU meters in “Audio Settings” on desktop/Firefox (I have just checked the Android app, I cannot find anything similar to the mentioned microphone VU meters there).

Thanks again for the detailed and informative answers!

Could be. Our servers are on well connected POPs, but it could be.

You can if you hover over the “signal bars” on the desktop browser. Then in more info you’ll see the transport IPs and if it’s P2P or not.