Using Jitsi on incompatible android device

i have an android device but jitsi app is uncompatible , how i can using jitsi by this device on browser ?

I don’t know if browser use can be forced, what Android version are you using ?

Jitsi Meet requires Android 5 or newer, I doubt your device has a recent enough browser that would support all WebRTC features.